[BUG-12867] Perspective view changed to empty folder

I had a view in perspective.
This view changed random to an empty folder, without an error or something.
Also I can’t find something strange in the logs.
This already happened twice.

How can this happen?
How do I get my views back?

what build and OS are you running?

I just updated to the newest version.
I dont know my previous build but that build is updated less than a week ago.
Also I notice when I browse the views trough an embedded view path browser I see that it is a view, but in the project browser it is a empty folder. I can select the view in the embedded view path browser but cannot select OK when I choose that view.

I am running on OS windows 7.

Mine did this when I

  1. Copied JSON to Notepad++
  2. Removed the Thumbnail at the bottom which was Tens of Thousands of lines long :dizzy_face:
    2a. (Because I wanted it to be easier to move around in Notepad++)
  3. Copied it back to a test view.

This also corrupted the project!
Here is an example of the errors I started getting on the server:

Please learn from my example! :rofl:

I can not copy the json like i can do with a view :frowning:
And I did not copy any json before to that view

Here an example.
The view is not reachable :frowning:

Oh, that’s weird.

When I double-clicked my broken views, it would load and say ‘no-project’.

Did your project throw any errors on the server logs?

just a lot of binding errors from another view.

ComponentModel 22Feb2019 14:25:50 Error creating ‘tag’ binding on property ‘props.text’
java.lang.IllegalArgumentException: Malformed path: 1

at com.inductiveautomation.ignition.common.JsonPath.parse(JsonPath.java:199)

at com.inductiveautomation.ignition.common.JsonUtilities.read(JsonUtilities.java:181)

at com.inductiveautomation.ignition.common.JsonUtilities.readString(JsonUtilities.java:59)

at com.inductiveautomation.perspective.gateway.binding.tag.TagBindingConfig.referencesFromJson(TagBindingConfig.java:48)

at com.inductiveautomation.perspective.gateway.binding.tag.TagBindingConfig.fromJson(TagBindingConfig.java:71)

at com.inductiveautomation.perspective.gateway.binding.tag.TagBindingFactory.create(TagBindingFactory.java:40)

at com.inductiveautomation.perspective.gateway.binding.tag.TagBindingFactory.create(TagBindingFactory.java:20)

at com.inductiveautomation.perspective.gateway.binding.BindingRegistryImpl.createBinding(BindingRegistryImpl.java:94)

at com.inductiveautomation.perspective.gateway.model.AbstractBindingHarness.(AbstractBindingHarness.java:63)

at com.inductiveautomation.perspective.gateway.model.ElementBindingHarness.(ElementBindingHarness.java:23)

at com.inductiveautomation.perspective.gateway.model.ElementBindingHarness.lambda$newFactory$0(ElementBindingHarness.java:28)

at com.inductiveautomation.perspective.gateway.model.BindingCollection.create(BindingCollection.java:59)

at com.inductiveautomation.perspective.gateway.model.ComponentModel.(ComponentModel.java:96)

at com.inductiveautomation.perspective.gateway.model.ComponentModel.initChildren(ComponentModel.java:128)

at com.inductiveautomation.perspective.gateway.model.ComponentModel.(ComponentModel.java:94)

at com.inductiveautomation.perspective.gateway.model.ViewModel.initRoot(ViewModel.java:193)

at com.inductiveautomation.perspective.gateway.model.ViewModel.(ViewModel.java:107)

at com.inductiveautomation.perspective.gateway.session.PerspectiveProjectSession.createViewModel(PerspectiveProjectSession.java:163)

at com.inductiveautomation.perspective.gateway.model.PageModel$Handlers.lambda$null$14(PageModel.java:709)

at com.inductiveautomation.perspective.gateway.api.LoggingContext.mdc(LoggingContext.java:54)

at com.inductiveautomation.perspective.gateway.model.PageModel$Handlers.lambda$startView$15(PageModel.java:700)

at java.base/java.util.concurrent.CompletableFuture$UniAccept.tryFire(Unknown Source)

at java.base/java.util.concurrent.CompletableFuture$Completion.run(Unknown Source)

at com.inductiveautomation.ignition.common.util.ExecutionQueue$PollAndExecute.run(ExecutionQueue.java:123)

at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

at java.base/java.util.concurrent.FutureTask.run(Unknown Source)

at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)

at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.base/java.lang.Thread.run(Unknown Source)

This might not be the same thing but if you reset an SSL cert or restart your gateway with an active designer running you can see the designer think that all of your screens are gone. You’ll still see the screens in designer but when you try to open them it will say the screens aren’t found.

The fix is to simply reopen the designer after your SSL cert is applied and your gateway is running.

It’s easy to panic when the designer tells you that your screens aren’t found :slight_smile:

Yes, the first thing I’d try with this one is reopening your designer and see if it’s still happening.

If it is, make sure you install the latest designer (those update with daily patches) and see if that fixes it.

If it’s still happening, try a reboot to make sure everything is in normal condition and make sure you’re not having network issues between your designer and the gateway server.

I literally just had this problem and it turned out it was being caused by one of our IT guys resetting my SSL cert and restarting my gateway repeatedly while I was doing development. I didn’t end up losing anything. It just looked like I had lost everything.

Thanks for the reaction, I tried to login at the server where the gateway is places too reach it at it’s own localhost, but it did not succeed. So it’s not a network problem.

I already made some reboots.
I already have the latest version of ignition installed.

Also it is just http, it does not have an SSL cert.

Digression, but FYI there is a fix for this coming in the upcoming nightlies. The thumbnail data was never meant to go into the json on copy.

1 Like

This issue was fixed in the build that was uploaded today (3/14). Please let us know if you continue to see this behavior after upgrading.

I am using 8.0.3 and have just experienced this same issue. Several views have turned into empty folders. Tried restarting the gateway and designer, have not been able to figure out a way to bring them back. I am pretty sure this bug has not been fully resolved yet.