Debian and Ignition Designer and Client

I just loaded up a fresh VM with Debian 10 (latest from their website) and installed the Ignition Gateway on it (8.0.12). My issue is I can’t get the designer or client going on it.

After extracting the .tar.gz files nothing (appears to) happens when I try to run the visionclientlauncher.desktop file. With Ubuntu I would get the untrusted application popup. Running the .sh file directly doesn’t seem to do anything, but if I add some “echo” lines in it I can see that it gets through to the end.

Any ideas? I’m not a Linux guru by any stretch so hopefully it’s something obvious.

EDIT: I’ve also installed JRE (sudo apt-get install default-jre) with no change. If I recall correctly I had to install the Gateway using the Terminal as double-clicking didn’t work.

Past the launcher.desktop file, there should be an app directory that contains a direct .sh file - if you make that executable (chmod +x designerlauncher.sh) can you then directly execute it (./designerlauncher.sh)?

I was originally doing that without success (running the .sh file directly). That includes trying to run it directly or after using su to use the root account.

I ended up adding the account I was logged into to the “sudo” group (https://linuxize.com/post/how-to-create-a-sudo-user-on-debian/). It seems like that was the issue I can run the .sh file and open the Client and Designer launcher windows.

Part of the issue is that it seems like Ubuntu and Debian prompt you differently during startup. Ubuntu has you create an administrator account during installation (which is what I was using when setting up Ignition) while Debian has you create a root password and a standard account.

Perhaps a future improvement to the .sh file would be to add a check if the user running the file has sufficient privileges?

That’s…pretty odd - nothing in the designerlauncher.sh/clientlauncher.sh files should require sudo. Maybe the file itself got marked with odd permissions in some way.

I still can’t open the .desktop files (including the created shortcuts) - I have to run the .sh files instead. The shortcuts that the launchers createe also don’t have the standard Ignition icons.
image

Might be a more general Debian problem? https://askubuntu.com/a/1187941

Thanks for that link. Somehow in my several hours of Googling I didn’t come across that one.

I was able to use the second option successfully:

  1. Add the .desktop file inside the ~/.local/share/applications and then it will appear in the App launcher, so you can add it to the Dock (add to favorites) and copy to the Desktop folder to add to Desktop.

The key part there was reading the whole comment and then navigating to the App launcher I was able to right click on the icon and add it to the favorites. This icon then works to launch the vision client.

I then used the “Dash to Dock” as described here (https://askubuntu.com/questions/792180/how-to-make-gnomes-activities-bar-always-visible) to make the dash always visible (similar to the default behavior in Ubuntu 18.04). This will allow an operator to more easily launch the Ignition application.

image

1 Like

I’m getting another Debian VM going and have had another opportunity to work through this.

I think that part of the issue is with the .desktop file. Now, keep in mind that I know nothing about .desktop files or bash.

Here’s a screenshot of the stock bash file:
image

It looks like the path to the icon image is hard coded to where the .tar.gz file was extracted. However, the Exec line points to a relative path (to where the .desktop file is being executed from, I think). It looks like when you copy the .desktop file to the ~/.local/share/applications directory it breaks the relative path to where the .sh file is located.

If you edit the .desktop file to hard reference the icon and sh file paths things appear to work. All this can be done without sudo.