7.6 Alarm Journal Source Filter Wildcard Not Working

Hey guys,

I don’t think the wild card is working correctly for the Alarm Journal Source Filter. If I encase a folder name with * (example: Air Compressor Room) I will get the list of alarms in the Alarm Status Table, but I will not get anything back in the Alarm Journal Table. Both source filter descriptions say that they support the wild card character but that does not seem to be the case. FYI.

I ran into this as well. I’m assuming the filter would be same as what is used for the Alarm Status Table.


The underlying filter should essentially be the same, though in the case of the journal, the filter is also used in building the query, so there could be something there.

It would probably be useful for you guys to do a few things for me:

  1. Describe the filters you’re trying to use, in both the status and journal scenarios, and exactly where you’re using them. It’s possible they get applied slightly differently in different situations, like when you use the source filter property on the component, vs. the actual filter popup on the the component during runtime.

  2. Try turning a few loggers on an see what information you get:
    “Alarming.Journal.Query” to trace will show the query, the filter, and various details about event counts/data.
    “Alarming.Query.Filter” to trace will show which particular conditions are causing events to fail.

Let me know what you find, or post wrapper logs for me to take a look at after you run a few queries.


Sure, I did this on my development server because when I tried it on my production server it spammed the console log with about 8 million lines. :stuck_out_tongue:

I’m using the Source Filter in the property editor of the journal component:

Here are the logs:
logs.bin.gz (409 KB)


Ok, sure enough, the journal table was interpreting that field wrong. It will be fixed for 7.6.2, however, you can get around it by using the “search filter” instead. That filter searches source OR display path, but if you use the filter: “tag:Training” you should get what you want, in this case (since you’re trying to filter down to tags under the “Training Tags” folder, right?)


In this example, yes. I’m not in a hurry for it. I was able to accomplish what I wanted to by using the display path filter instead. I just noticed that it didn’t seem to be working correctly. Thanks for fixing it!

I have created a new alarm journal. All setting were left default but I want to only store alarms that come from a specific realtime tag provider so I entered the tag provider name into the Filter by Alarm Source field. No alarms were being stored so I entered the same name into the Filter by Display Path or Source instead. Still no alarms being stored. If I leave both fields blank, it will store alarms as expected.

Realtime tag provider: PFLine
Sample record from alarm_events table: prov:PFLine:/tag:Line033/Ovens/Oven1/AlarmCode:/alm:Oven1 Temp Alarm (Low)

I am entering PFLine into the filter textbox fields. I have tried using wildcards before and after but still not working. What am I doing wrong? I am running Ignition 7.9.3.