Accessing custom parameter of a UDT instance inside a popup window

From the dataset editor I observe that the dynamic tag binding using indirection is working fine, but the tag historian is storing the data only for Tank 1 (PV & SV), not for other tanks Tank 2 on wards, although i have enabled history for these two tags in the Tank UDT for Tank itself!

I was getting the chart displayed only for the first Tank, but when I opened the popup window for other Tanks by clicking on the respective template instance, I was not getting any chart displayed! So I thought there is an error in dynamic tag binding! I never suspected the data for only one tank1 is getting historised not for others? Any clue why it might be happening?

I need to open the data base and see what’s getting stored there. Any hint whats the easiest way to check the contents of the historian tables thru designer?! Or do I have to see only thru the SQL manager tool?

Found the problem! I had not selected the Storage Provider for the two tags in the UDT! So the tables for the two tags didn’t exist in DB! Now everything is working as expected! The Indirection for Tag Pens works as demonstrated in the IU video for Indirect chart display!

(But I wonder how the chart for Tank 1 was working without the selection of Storage Provider!)

Thanks all for your time in helping me out. It was my mistake!

regards

Perhaps tag editing menu should not allow leaving Storage Provider blank when history is enabled on a tag in the editor to disable erroneous data entering in the tag configuration. The history enabled without specifying storage provider doesn’t make sense!

How to achieve the same in perspective? That is, when you pass a UDT as a Parameter in a template view, then how to access the udt number (such as tankNumber in above example) which is its internal parameter in the UDT?

No differently than in Vision

I created a custom property for the TankNum in the Template View and tried to bind it with the TankUDT which is defined as an Input/Output parameter in the Template View, I get InvalidPathSyntax error! How to specify the path I tried {view.params.TankUDT}::Meta.TagPath but that too doesn’t work! (gives syntax error invalid character “:”!)

I am stuck!

I’ve never used udt types in Perspective at all, but can you select the meta tagpath from the UDT type param from the property selector?
Screenshot_20220125-170238_Chrome
I’d expect it would be a part of the {}
Eg
{view.params.TankUDT::Meta.TagPath} or something