[BUG-16490] Problem in Programmable Device Simmulator

Hi @pturmel, thanks for the answer. How can I change my locale in the designer? I think I already have locale in ‘en’, becasue when I execute “system.util.getLocale()” in the script console, it print me ‘en’.

Please re-read. Change your gateways’ locales to ‘en’. The simulator runs in the gateway.

Yes, but how can I change this?

Normally you’d pick the locale when installing the OS, but I’m sure there’s ways to change it afterwards. But more importantly, you can override the locale for Ignition in ignition.conf. (I don’t recall the actual setting key, but it has been posted on this forum a few times.)

You can force the local from a file in the Ignition installation folder, data/ignition.conf. You will see a line:

#wrapper.lang=en_US # en_US or ja_JP

remove the first # so it becomes:

wrapper.lang=en_US # en_US or ja_JP

Save the file and restart Ignition.

Garth

1 Like

Thanks. But this doesn’t work either.