[BUG] UDT Import

  1. The behavior you unexpectedly encountered - Missing parameters from UDT import:
    Screenshot from Designer v8.0Beta

Screenshot from Designer v7.9.9 (original UDT)

2. The behavior you were expecting to see - I expected to see the imported parameters to be populated and available.
Some UDT’s imported just fine:
Screenshot from Designer v8.0Beta

Screenshot from Designer v7.9.9 (original UDT)

  1. A list of the steps you took that exposed the issue - including your starting point.
    Ignition Designer 7.9.9
    Right click UDT, select export and name file

Ignition Designer 8.0B1
Right click “Data Types” folder and select import. Select import file from v7.9.9.

  1. A list of helpful information about the situation you were in, such as:
    Ignition version number 8.0.0-beta1
    Browser and version number Chrome Version 64.0.3282.167 (Official Build) (64-bit)
    Java version number 1.8.0_191-b12

Can you post the .xml file for one of the UDTs that didn’t import correctly? If you don’t want to post it here directly, feel free to PM me.

Please see below…

tag_UDT_NonWorking.xml (6.8 KB)

I just renamed the existing UDT (added “1”). Tried the import again, this time it worked.

Previously I imported multiple tags/UDT’s during a single import. Not sure if this has any impact…

A post was split to a new topic: Issues With UDTs

The export only has the single parameter in it:

     <Property name="PLC" type="String">WIMRP_Main_PLC</Property>

What version of the application was the export generated from? I am leaning toward this being an issue with the existing application exporting XML, but would like to confirm I can replicate.

7.9.9, existing system running a project within our facility.

I have attempted to duplicate this issue in 7.9, but I have been successful yet. Once point of clarification, in the screenshots the name of the UDT Definition is Level Config but in the import file you provided the UDT Definition is AI_CLX (Intake Only). I just want to double check the file is being generated from a tag with the same parameters.

If you confirm that the UDT export is still missing any parameters upon export from 7.9.9, I ask that you contact support to have them try and narrow down reproduction steps as it is an issue with the currently released version of Ignition.

To make your data work to test with 8.0, is it possible to use a backup of the 7.9.9 gateway on this system?

A post was split to a new topic: UDTs not Connecting to OPC Devices

I’m closing this due to inactivity. If you are still having issues, please feel free to open a new post.