Designer startup : Verifying Signature of Designer

I am experiencing the same thing, no internet connection and self signed certificate. I disabled the "Check for server certificate revocation" in the AD and it still takes noticeable amount of time to open the designer .

That has no effect on Ignition.

Thanks Michael, this was really helpful for preventing the popup when launching client apps on the gateway machine. I've done the same on some other machines, but this doesn't seem to prevent the popup hanging when launching clients on these devices. I've had a look at the DNS traffic and have only seen and, so I would think they'd be prevented by those lines in the host file but evidently not. Have you experienced similar?

I haven't, but I did notice in today's nightly release notes for 8.1.40 that they're adding an option for the designer launcher to specify how this should be handled so that air gapped systems can bypass the CRL check that hangs things up. The only other thing I would suspect is if the port/URL it reaches out to check is listening on your localhost, then it could be waiting on it to timeout/return something.