Gateway won't start

MacBookPro, OSX 10.6.4

So I downloaded the zip, installed it exactly as per the README, and could not get the gateway to start.

[quote]# ignition start
Starting Ignition Gateway…

ignition status

Ignition Gateway is not running.
[/quote]
There was also nothing in the log file. I then uncommented the #wrapper.java.command.loglevel=INFO
line in ignition.conf and finally got some results in the log:

INFO | jvm 1 | 2010/09/14 08:49:19 | WrapperSimpleApp: java.lang.RuntimeException: java.lang.IllegalStateException: Trying to build context for "main" but a required config.xml property is missing INFO | jvm 1 | 2010/09/14 08:49:19 | WrapperSimpleApp: at com.inductiveautomation.catapult.Catapult.main(Catapult.java:84) INFO | jvm 1 | 2010/09/14 08:49:19 | WrapperSimpleApp: at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) INFO | jvm 1 | 2010/09/14 08:49:19 | WrapperSimpleApp: at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) INFO | jvm 1 | 2010/09/14 08:49:19 | WrapperSimpleApp: at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) INFO | jvm 1 | 2010/09/14 08:49:19 | WrapperSimpleApp: at java.lang.reflect.Method.invoke(Method.java:597) INFO | jvm 1 | 2010/09/14 08:49:19 | WrapperSimpleApp: at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:244) INFO | jvm 1 | 2010/09/14 08:49:19 | WrapperSimpleApp: at java.lang.Thread.run(Thread.java:637) INFO | jvm 1 | 2010/09/14 08:49:19 | WrapperSimpleApp: Caused by: java.lang.IllegalStateException: Trying to build context for "main" but a required config.xml property is missing INFO | jvm 1 | 2010/09/14 08:49:19 | WrapperSimpleApp: at com.inductiveautomation.catapult.CatapultBase.buildContexts(CatapultBase.java:587) INFO | jvm 1 | 2010/09/14 08:49:19 | WrapperSimpleApp: at com.inductiveautomation.catapult.CatapultBase.startTomcat(CatapultBase.java:183) INFO | jvm 1 | 2010/09/14 08:49:19 | WrapperSimpleApp: at com.inductiveautomation.catapult.Catapult.main(Catapult.java:82) INFO | jvm 1 | 2010/09/14 08:49:19 | WrapperSimpleApp: ... 6 more

The problem is, I don’t know which config.xml properties need to be set in order to build the context. Also, what do the permissions/user/group need to be for the /usr/local/ignition folder and files, i.e what access level and user/group does ignition need to run under?

And obviously localhost:8088 won’t pull up the Ignition Gateway server, because it isn’t running. I did have a local Apache server running, but shut it down before trying Ignition. Could this be causing part of the problem or be a future problem? Is Ignition assuming certain files or symlinks are in certain locations?

Thanks in advance!

The config.xml should be in the root directory of Ignition and the contents look like:[code]<?xml version="1.0" encoding="UTF-8" standalone="no"?>

Catapult Properties main 8088 8043 ctx0 7.1.6.5739 [/code] Whatever user is starting Ignition needs to have read/write access to the following files and folders:

contexts (folder)
request
response

You need to have execute permissions on the following files:

ignition-gateway
ignition.sh
gch.sh

Hope this helps.

Strange, my config.xml was missing the last two entries.

So I added them in, and tried to restart. Progress!
The server starts, but I get a 404 error. Also, log shows these errors:

INFO | jvm 1 | 2010/09/14 13:03:19 | WrapperManager: Initializing... INFO | jvm 1 | 2010/09/14 13:03:21 | Error updating web.xml for context main INFO | jvm 1 | 2010/09/14 13:03:21 | java.io.FileNotFoundException: /usr/local/ignition/tomcat/webapps/ctx0/WEB-INF/web.xml (No such file or directory) INFO | jvm 1 | 2010/09/14 13:03:21 | at java.io.FileInputStream.open(Native Method) INFO | jvm 1 | 2010/09/14 13:03:21 | at java.io.FileInputStream.<init>(FileInputStream.java:106) INFO | jvm 1 | 2010/09/14 13:03:21 | at com.inductiveautomation.catapult.util.FileUtil.readAll(FileUtil.java:81) INFO | jvm 1 | 2010/09/14 13:03:21 | at com.inductiveautomation.catapult.CatapultBase.updateWebXML(CatapultBase.java:615) INFO | jvm 1 | 2010/09/14 13:03:21 | at com.inductiveautomation.catapult.CatapultBase.buildContexts(CatapultBase.java:599) INFO | jvm 1 | 2010/09/14 13:03:21 | at com.inductiveautomation.catapult.CatapultBase.startTomcat(CatapultBase.java:183) INFO | jvm 1 | 2010/09/14 13:03:21 | at com.inductiveautomation.catapult.Catapult.main(Catapult.java:82) INFO | jvm 1 | 2010/09/14 13:03:21 | at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) INFO | jvm 1 | 2010/09/14 13:03:21 | at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) INFO | jvm 1 | 2010/09/14 13:03:21 | at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) INFO | jvm 1 | 2010/09/14 13:03:21 | at java.lang.reflect.Method.invoke(Method.java:597) INFO | jvm 1 | 2010/09/14 13:03:21 | at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:244) INFO | jvm 1 | 2010/09/14 13:03:21 | at java.lang.Thread.run(Thread.java:637) ... ... INFO | jvm 1 | 2010/09/14 13:03:21 | SEVERE: Error starting static Resources INFO | jvm 1 | 2010/09/14 13:03:21 | java.lang.IllegalArgumentException: Document base /usr/local/ignition/tomcat/webapps/ctx0 does not exist or is not a readable directory INFO | jvm 1 | 2010/09/14 13:03:21 | at org.apache.naming.resources.FileDirContext.setDocBase(FileDirContext.java:141) INFO | jvm 1 | 2010/09/14 13:03:21 | at org.apache.catalina.core.StandardContext.resourcesStart(StandardContext.java:3957) INFO | jvm 1 | 2010/09/14 13:03:21 | at org.apache.catalina.core.StandardContext.start(StandardContext.java:4126) INFO | jvm 1 | 2010/09/14 13:03:21 | at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045) INFO | jvm 1 | 2010/09/14 13:03:21 | at org.apache.catalina.core.StandardHost.start(StandardHost.java:719) INFO | jvm 1 | 2010/09/14 13:03:21 | at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045) INFO | jvm 1 | 2010/09/14 13:03:21 | at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443) INFO | jvm 1 | 2010/09/14 13:03:21 | at org.apache.catalina.startup.Embedded.start(Embedded.java:825) INFO | jvm 1 | 2010/09/14 13:03:21 | at com.inductiveautomation.catapult.CatapultBase.startTomcat(CatapultBase.java:207) INFO | jvm 1 | 2010/09/14 13:03:21 | at com.inductiveautomation.catapult.Catapult.main(Catapult.java:82) INFO | jvm 1 | 2010/09/14 13:03:21 | at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) INFO | jvm 1 | 2010/09/14 13:03:21 | at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) INFO | jvm 1 | 2010/09/14 13:03:21 | at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) INFO | jvm 1 | 2010/09/14 13:03:21 | at java.lang.reflect.Method.invoke(Method.java:597) INFO | jvm 1 | 2010/09/14 13:03:21 | at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:244) INFO | jvm 1 | 2010/09/14 13:03:21 | at java.lang.Thread.run(Thread.java:637) INFO | jvm 1 | 2010/09/14 13:03:21 | Sep 14, 2010 1:03:21 PM org.apache.catalina.core.StandardContext start INFO | jvm 1 | 2010/09/14 13:03:21 | SEVERE: Error in resourceStart() INFO | jvm 1 | 2010/09/14 13:03:21 | Sep 14, 2010 1:03:21 PM org.apache.catalina.core.StandardContext start INFO | jvm 1 | 2010/09/14 13:03:21 | SEVERE: Error getConfigured INFO | jvm 1 | 2010/09/14 13:03:21 | Sep 14, 2010 1:03:21 PM org.apache.catalina.core.StandardContext start INFO | jvm 1 | 2010/09/14 13:03:21 | SEVERE: Context [/main] startup failed due to previous errors

The folder /usr/local/ignition/tomcat/webapps/ctx0 does not exist: all I have in webapps is a ROOT folder.
The ignition file structure permissions are fully open, yet it’s not creating that folder?

Should I copy the web.xml from tomcat/conf to tomcat/webapps/ctx0?

Reset your config.xml file to the _clean one in the root of Ignition. The clean does not have the last two entries that I posted. Ignition will alter the config.xml adding those two entries. Ignition will also create the ctx0 folder. I think you are still running into permission problems. Do a chmod -R 777 ./* on that directory just to try.

Prior to reading your last post, I decided to purge and re-install ignition. I thought maybe something went askew with permissions somewhere, and it only took a few seconds to do.
Again I re-set the permissions like last time, by the README.txt and with your last post’s hints. No 777, just normal perms.
Then I got an Address already in use<null>:8088error. So checked ports with # lsof -Pnl +M -i4 and for some reason, a java (previous gateway?) process was blocking ports 8088 and 8043.
I killed the process, restarted the server, and it worked. Now the main Gateway page loads.

SUGGESTION: Perhaps the additional permissions and executable info could be added into the README? It would have been helpful when troubleshooting this problem.

Thanks for your help!

Great! We are in the process of making a better Mac OS X installer so your suggestion is noted.

I have a similar problem but with different circumstances. I upgraded to the latest version and all was working fine until I rebooted the machine. Now the Gateway fails to start and the event log shows: The Ignition Gateway service terminated with service-specific error Incorrect function… I can manually restart it but it shuts down immediately.

I removed the Ignition program and reinstalled. No luck.

Running Windows 7. My permissions are “full control”. I’ve tried setting the service logon to both Local System Account and the Network Service account.

Suggestions?

Thanks for your help.

Can you post the contents of the wrapper.log file located in Ignition’s install directory?

STATUS | wrapper | 2010/10/04 18:57:13 | --> Wrapper Started as Service
STATUS | wrapper | 2010/10/04 18:57:13 | Java Service Wrapper Standard Edition 32-bit 3.3.9
STATUS | wrapper | 2010/10/04 18:57:13 | Copyright © 1999-2009 Tanuki Software, Ltd. All Rights Reserved.
STATUS | wrapper | 2010/10/04 18:57:13 | wrapper.tanukisoftware.org
STATUS | wrapper | 2010/10/04 18:57:13 | Licensed to Inductive Automation for Ignition Gateway
STATUS | wrapper | 2010/10/04 18:57:13 |
STATUS | wrapper | 2010/10/04 18:57:13 | Launching a JVM…
INFO | jvm 1 | 2010/10/04 18:57:14 | WrapperManager: Initializing…
INFO | jvm 1 | 2010/10/04 18:57:19 | Oct 4, 2010 6:57:19 PM org.apache.catalina.startup.Embedded start
INFO | jvm 1 | 2010/10/04 18:57:19 | INFO: Starting tomcat server
INFO | jvm 1 | 2010/10/04 18:57:19 | Oct 4, 2010 6:57:19 PM org.apache.catalina.core.StandardEngine start
INFO | jvm 1 | 2010/10/04 18:57:19 | INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
INFO | jvm 1 | 2010/10/04 18:57:19 | Oct 4, 2010 6:57:19 PM org.apache.catalina.startup.DigesterFactory register
INFO | jvm 1 | 2010/10/04 18:57:19 | WARNING: Could not get url for /javax/servlet/jsp/resources/jsp_2_0.xsd
INFO | jvm 1 | 2010/10/04 18:57:19 | Oct 4, 2010 6:57:19 PM org.apache.catalina.startup.DigesterFactory register
INFO | jvm 1 | 2010/10/04 18:57:19 | WARNING: Could not get url for /javax/servlet/jsp/resources/jsp_2_1.xsd
INFO | jvm 1 | 2010/10/04 18:57:19 | Oct 4, 2010 6:57:19 PM org.apache.catalina.startup.DigesterFactory register
INFO | jvm 1 | 2010/10/04 18:57:19 | WARNING: Could not get url for /javax/servlet/jsp/resources/web-jsptaglibrary_1_1.dtd
INFO | jvm 1 | 2010/10/04 18:57:19 | Oct 4, 2010 6:57:19 PM org.apache.catalina.startup.DigesterFactory register
INFO | jvm 1 | 2010/10/04 18:57:19 | WARNING: Could not get url for /javax/servlet/jsp/resources/web-jsptaglibrary_1_2.dtd
INFO | jvm 1 | 2010/10/04 18:57:19 | Oct 4, 2010 6:57:19 PM org.apache.catalina.startup.DigesterFactory register
INFO | jvm 1 | 2010/10/04 18:57:19 | WARNING: Could not get url for /javax/servlet/jsp/resources/web-jsptaglibrary_2_0.xsd
INFO | jvm 1 | 2010/10/04 18:57:19 | Oct 4, 2010 6:57:19 PM org.apache.catalina.startup.DigesterFactory register
INFO | jvm 1 | 2010/10/04 18:57:19 | WARNING: Could not get url for /javax/servlet/jsp/resources/web-jsptaglibrary_2_1.xsd
INFO | jvm 1 | 2010/10/04 18:57:19 | INFO [SRClassLoader ] [18:57:19,773]: SRClassLoader init
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [SRContext ] [18:57:20,334]: Ignition["/main", state=STOPPED] ContextState = STARTING
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [BundleUtil ] [18:57:20,334]: Requested load of resource bundle ‘common’ for locale ‘en_US’, received bundle for ‘’
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [SRContext ] [18:57:20,350]: Starting Ignition 7.1.6 (b5739)
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [SRContext ] [18:57:20,350]: Reloading JDBC classloader.
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [SecureRandomProvider ] [18:57:20,475]: Creating SecureRandom object…
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [SecureRandomProvider ] [18:57:20,475]: Generating seed…
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [SecureRandomProvider ] [18:57:20,475]: … Seed Created.
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [SecureRandomProvider ] [18:57:20,475]: … SecureRandom Created.
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [BundleUtil ] [18:57:20,553]: Requested load of resource bundle ‘common’ for locale ‘en_US’, received bundle for ‘’
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [BundleUtil ] [18:57:20,553]: Requested load of resource bundle ‘gateway’ for locale ‘en_US’, received bundle for ‘’
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [Application ] [18:57:20,631]: [SRContext] init: Wicket core library initializer
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [RequestListenerInterface ] [18:57:20,631]: registered listener interface [RequestListenerInterface name=IBehaviorListener, method=public abstract void org.apache.wicket.behavior.IBehaviorListener.onRequest()]
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [RequestListenerInterface ] [18:57:20,631]: registered listener interface [RequestListenerInterface name=IBehaviorListener, method=public abstract void org.apache.wicket.behavior.IBehaviorListener.onRequest()]
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [RequestListenerInterface ] [18:57:20,631]: registered listener interface [RequestListenerInterface name=IFormSubmitListener, method=public abstract void org.apache.wicket.markup.html.form.IFormSubmitListener.onFormSubmitted()]
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [RequestListenerInterface ] [18:57:20,631]: registered listener interface [RequestListenerInterface name=IFormSubmitListener, method=public abstract void org.apache.wicket.markup.html.form.IFormSubmitListener.onFormSubmitted()]
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [RequestListenerInterface ] [18:57:20,646]: registered listener interface [RequestListenerInterface name=ILinkListener, method=public abstract void org.apache.wicket.markup.html.link.ILinkListener.onLinkClicked()]
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [RequestListenerInterface ] [18:57:20,646]: registered listener interface [RequestListenerInterface name=ILinkListener, method=public abstract void org.apache.wicket.markup.html.link.ILinkListener.onLinkClicked()]
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [RequestListenerInterface ] [18:57:20,646]: registered listener interface [RequestListenerInterface name=IOnChangeListener, method=public abstract void org.apache.wicket.markup.html.form.IOnChangeListener.onSelectionChanged()]
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [RequestListenerInterface ] [18:57:20,646]: registered listener interface [RequestListenerInterface name=IOnChangeListener, method=public abstract void org.apache.wicket.markup.html.form.IOnChangeListener.onSelectionChanged()]
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [RequestListenerInterface ] [18:57:20,646]: registered listener interface [RequestListenerInterface name=IRedirectListener, method=public abstract void org.apache.wicket.IRedirectListener.onRedirect()]
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [RequestListenerInterface ] [18:57:20,646]: registered listener interface [RequestListenerInterface name=IRedirectListener, method=public abstract void org.apache.wicket.IRedirectListener.onRedirect()]
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [RequestListenerInterface ] [18:57:20,646]: registered listener interface [RequestListenerInterface name=IResourceListener, method=public abstract void org.apache.wicket.IResourceListener.onResourceRequested()]
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [RequestListenerInterface ] [18:57:20,646]: registered listener interface [RequestListenerInterface name=IResourceListener, method=public abstract void org.apache.wicket.IResourceListener.onResourceRequested()]
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [RequestListenerInterface ] [18:57:20,646]: registered listener interface [RequestListenerInterface name=IActivePageBehaviorListener, method=public abstract void org.apache.wicket.behavior.IBehaviorListener.onRequest()]
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [RequestListenerInterface ] [18:57:20,646]: registered listener interface [RequestListenerInterface name=IActivePageBehaviorListener, method=public abstract void org.apache.wicket.behavior.IBehaviorListener.onRequest()]
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [Application ] [18:57:20,646]: [SRContext] init: Wicket extensions initializer
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [ClusterManagerImpl ] [18:57:20,662]: ClusterState = CONNECTING
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [WebApplication ] [18:57:20,662]: [SRContext] Started Wicket version 1.4.5 in deployment mode
INFO | jvm 1 | 2010/10/04 18:57:20 | Oct 4, 2010 6:57:20 PM org.apache.coyote.http11.Http11Protocol init
INFO | jvm 1 | 2010/10/04 18:57:20 | SEVERE: Error initializing endpoint
INFO | jvm 1 | 2010/10/04 18:57:20 | java.net.BindException: Address already in use: JVM_Bind:8088
INFO | jvm 1 | 2010/10/04 18:57:20 | at org.apache.tomcat.util.net.JIoEndpoint.init(JIoEndpoint.java:502)
INFO | jvm 1 | 2010/10/04 18:57:20 | at org.apache.coyote.http11.Http11Protocol.init(Http11Protocol.java:176)
INFO | jvm 1 | 2010/10/04 18:57:20 | at org.apache.catalina.connector.Connector.initialize(Connector.java:1058)
INFO | jvm 1 | 2010/10/04 18:57:20 | at org.apache.catalina.startup.Embedded.start(Embedded.java:830)
INFO | jvm 1 | 2010/10/04 18:57:20 | at com.inductiveautomation.catapult.CatapultBase.startTomcat(CatapultBase.java:207)
INFO | jvm 1 | 2010/10/04 18:57:20 | at com.inductiveautomation.catapult.Catapult.main(Catapult.java:82)
INFO | jvm 1 | 2010/10/04 18:57:20 | at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
INFO | jvm 1 | 2010/10/04 18:57:20 | at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
INFO | jvm 1 | 2010/10/04 18:57:20 | at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
INFO | jvm 1 | 2010/10/04 18:57:20 | at java.lang.reflect.Method.invoke(Unknown Source)
INFO | jvm 1 | 2010/10/04 18:57:20 | at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:244)
INFO | jvm 1 | 2010/10/04 18:57:20 | at java.lang.Thread.run(Unknown Source)
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp:
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp: Encountered an error running main:
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp: java.lang.RuntimeException: LifecycleException: Protocol handler initialization failed: java.net.BindException: Address already in use: JVM_Bind:8088
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp: at com.inductiveautomation.catapult.Catapult.main(Catapult.java:84)
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp: at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp: at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp: at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp: at java.lang.reflect.Method.invoke(Unknown Source)
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp: at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:244)
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp: at java.lang.Thread.run(Unknown Source)
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp: Caused by: LifecycleException: Protocol handler initialization failed: java.net.BindException: Address already in use: JVM_Bind:8088
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp: at org.apache.catalina.connector.Connector.initialize(Connector.java:1060)
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp: at org.apache.catalina.startup.Embedded.start(Embedded.java:830)
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp: at com.inductiveautomation.catapult.CatapultBase.startTomcat(CatapultBase.java:207)
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp: at com.inductiveautomation.catapult.Catapult.main(Catapult.java:82)
INFO | jvm 1 | 2010/10/04 18:57:20 | WrapperSimpleApp: … 6 more
INFO | jvm 1 | 2010/10/04 18:57:20 | INFO [JChannel ] [18:57:20,709]: JGroups version: 2.6.3.GA
INFO | jvm 1 | 2010/10/04 18:57:21 | WARN [SHARED_LOOPBACK ] [18:57:20,927]: failed to join /224.0.0.75:7500 on eth3: java.net.SocketException: Unrecognized Windows Sockets error: 0: no Inet4Address associated with interface
INFO | jvm 1 | 2010/10/04 18:57:21 | WARN [SHARED_LOOPBACK ] [18:57:20,958]: failed to join /224.0.0.75:7500 on net5: java.net.SocketException: Unrecognized Windows Sockets error: 0: no Inet4Address associated with interface
INFO | jvm 1 | 2010/10/04 18:57:21 | WARN [SHARED_LOOPBACK ] [18:57:20,958]: failed to join /224.0.0.75:7500 on net7: java.net.SocketException: Unrecognized Windows Sockets error: 0: no Inet4Address associated with interface
INFO | jvm 1 | 2010/10/04 18:57:21 | INFO [ClusterManagerImpl ] [18:57:21,504]: ClusterState = JOINING
INFO | jvm 1 | 2010/10/04 18:57:23 | Please use CMSClassUnloadingEnabled in place of CMSPermGenSweepingEnabled in the future
STATUS | wrapper | 2010/10/04 18:57:23 | <-- Wrapper Stopped

The log file shows that port 8088 is already in use. You need to find the process that is bound to that port and kill it or change the Ignition port.

A file of port and process info is attached. I can close port 8088 but it reopens in a few seconds. Unless you see something promising here I’d like to abandon this approach and change the port. I think I’m dealing with a strange quirk on this particular machine.

However, since I can’t get the gateway running I’m perplexed as to how to make a port change. The manual says:
The port can only be set through the Gateway Control Utility. It cannot be changed from the gateway
configuration portal.
If the port is already in use, the Ignition gateway will not be allowed to start. In this case, the Gateway
Control Utility may be used from the server machine to select a different port for the server.

Can you elaborate on that? I don’t understand the last sentence.

Thanks,

Charlie
tcpports.txt (16 KB)

Hi,

The port is normally changed through the GCU, but it simply resides in an XML file, so it may be easier for you to just edit that.

Go to “{install directory}\Ignition\tomcat\webapps\ctx0\WEB-INF” and edit “web.xml”. Look for “http.port” and change the value to whatever you would like.

After restarting the gateway, you should be up and running.

Regards,

I had the same issue and turns out Wonderware’s aaLogger.exe was the culprit.
I found it using SysInternals TCPView. Very handy app!

technet.microsoft.com/en-us/sys … 97437.aspx

I am having the same issue. I cannot find the XML file that is described in this forum. “{install directory}\Ignition\tomcat\webapps\ctx0\WEB-INF” and edit “web.xml”