Ignition 8 Client on Raspberry PI

Correct, but will get errors if not on a 64bit os.

There errors were from running the launcher, the launcher in turn is running launchclient.jar which has no native components.

Or am I missing something?

Launch command line should be something like:

/home/pgriffith/.ignition/clientlauncher-data/launchclient.jar -Djavaws.sr.gateway.addr.0= -Djavaws.sr.launchts=1556560041806 -Djavaws.sr.main=com.inductiveautomation.factorypmi.application.runtime.ClientLaunchHook -Djavaws.sr.platform.edition= -Djavaws.ignition.sso=true -Xms32M -Xmx256M -Djavaws.sr.memory.init=32M -Djavaws.sr.memory.max=256M -Dsun.java2d.d3d=false -Dsun.java2d.noddraw=false -Djavaws.sr.screen=0 -Djavaws.sr.scope=C -Djavaws.sr.project=Test com.inductiveautomation.ignition.client.launch.BootstrapSwing

Or, more legibly:


Let me see what I can do when I get the system back online. Reflashing now with 64bit os.

Where can I find launchclient.jar?


obviously, replace “username” with the user you’re logged in as.

Might be easier to take what PGriffith posted, but modify the username

Hardly correct. Ignition isn’t installed on the pi. No .ignition directory exists.

I did get the legacyclientlauncher.tar.gz downloaded from a 7.9 install and ran that on the pi. It worked fine with the 7.9 edge server it was connecting to.

I modified the project name, the platform.edition to blank, and the gateway.addr to the correct ip. I got errors regarding unpacking java-cup-10k.jar

Are the legacy client launcher files no longer available in 8?

You can get a copy of clientlauncher.jar from the lib/core/launch folder of an Ignition 8 install. The location @Paul.Scott suggested is where it ends up when the launcher downloads it but you aren’t able to get that far.

The legacy launchers are not available with Ignition 8.

So it appears that arm is not compatible with Ignition v8. Is this known/intentional? How long will 7.9 be supported?

7.9 is an LTS version so it’s supported for 5 years from the first release, so it’s supported until December 2021 in this case.

Ignition 8.0 supports running the gateway on ARM and we’re aware the Vision Client and Launchers don’t run on ARM. I’m not sure if this will change significantly. We may be able to ship launchers that have native components compatible with ARM sometime in the future but it would still require that the system have its own JDK installed because the ARM JDKs we license and ship with are headless.

I would also be greatly interested in developments in this issue.
We calculated a project with multiple sites with each site using a PI for minor display functionality.
Since ARM is no longer supported we would have to buy perspective licences for multiple gateways.

I think this is a rather big step all of a sudden…

this post has a workaround for running Vision clients on 32-bit machines, including RPi.

It’s actually a little more broad than that. The scripts bypass the launcher and directly launch a Vision client using whatever JRE is installed on the system.

1 Like

Attached is a modified launcher script for use with Liberica Java, along with a how-to text file.

I picked Liberica for two reasons.

  1. It has an apt repository, and appeals to my sense of lazy.
  2. They claim it supports JavaFX on armhf, although I have not yet tried it.

piLaunchV8.zip (2.3 KB)


Neat, hadn’t heard of Liberica until now.

Following up on this thread some. We recently got a few of the pi4’s. We also came across from what I understand is a 64bit OS. Trying to keep native and simple we downloaded the vision client launcher from our gateway. when we run the jar file nothing happens. We have openjdk 11 installed. We are in process of migrating off of 7.9 to 8. hoping to find out if there is a fluid path for this to finally work nicely. We have used Jordans info above and have seen it work on the pi3 and would probably work on the pi4 but on the 32 bit os. So far we execute the jar file and nothing happens. We will do more testing but I figured I would see if any progress has happened from others on the forum.

1 Like

I would also like to see a better solution for this! There needs to be an elegant way to use a Pi with Ignition 8. If it is any help, you can use an Intel compute stick running Lubuntu 64bit with minimal issues. The price is a bit more, but the one we have for testing is working well.

1 Like

Which OS are you using? Pi OS is still 32 bit.


Here is a link to what we have tested/testing

In trying to use sudo apt-get install bellsoft-java14 we end up at a broken dependency for libgtk2.0:armhf
“broken packages”…
using sudo apt-get cache search we see version going all the way to 11.
11 is the one that doesn’t have broken packages. Dont know if this problem with 14 is the last one on the list to get a client working or just one of many…