Mobile keyboard doesn't appear for password input field

As I test in v8.1.12 the mobile keyboard doesn’t appear for password input files component in both browser and mobile app.
I also test this for both apple and Android OS.
The interesting thing is that when I check desktop mode in Chrome the keyboard appear.

I just did a quick test with an Android Pixel 3 with both the latest Mobile App and Chrome, using the Sample Quickstart project on a 8.1.13 gateway and navigating to Components/Inputs/Password Field and they both bring up the keyboard with no issues.

Could you put the password component in a popup and test it again
May be because I use it in popup I see this problem it seems keyboard trying to come up and disappear again very fast

Judging from the right border radius, it looks like the popup is out of the screen on the left?
Try making it a bit smaller, popups leaving the edge of the screen sometimes do weird things.


I just created a project with two views. With the first view, I put a button on it. On the second view (Flex Container), I added a Password component. I configured the event on the button to open the second page as a popup.

I then used both the latest Mobile App and Chrome Browser on Android. The keyboard worked on both with no issues. (The Popup was sized to fit my screen)

I then made the popup larger then my mobile screen, and yes the keyboard no longer popped up when attempting to use the field. So, thumbs up to victordcq.

Since my popup was “resizable”, as soon as I resized it to fit the screen in a live session, the keyboard appeared as desired.

I will check to see if this is a known issue.


Based on my further investigation, the link I attached below is/was the resolution to this specific issue. So, it is not an open issue at this time. So I have disassociated this Forum Thread to the issue I had earlier.

Resizing the popup or using the “Viewport Bound” should resolve the issue.

Old , disregard:
I did find that this is an existing issue. Please resize the popup view to be with in the size of the screen and see if that resolves the issue for you.

1 Like

I also found this information, which might be very useful in your situation. It has to do with the “Viewport Bound” option for a popup.

More information on the Action Setting can be found here:

1 Like

Yes thanks it fix the problem

1 Like