No tag Historian tables created in database

Was having the similar issues as of Ignition version 8.0.3 using MySQL version 5.7-- tables weren’t being created even though the connection was valid and rooted. I could create tables using the DB query browser. Restarting gateway didn’t help.

I was able to resolve the issue by manually adding the Connector/J (I used version 8.0.17) as a custom driver using all the regular options you’d use in the default-provided MySQL Connector/J driver. New connections using this custom driver worked.

I’m not sure if I caused this somehow or if the issue is back as of Ignition 8, but either way, hope this helps someone.

1 Like

Does anyone found out this issue. (java.sql.SQLSyntaxErrorException: Table ‘test.sqlth_drv’ doesn’t exist)

I know this issue is a couple of years old however, I experienced this same problem. Particularly with Microsoft SQL Server. Each time I would use tag historian, each event was being passed to the Store and Forward Stores Quarantine with the error ‘sqlth_drv’ is an invalid object. The problem ended up being that the user properties and permissions that ignition was using to connect to the database didn’t have the correct permissions and database references. Opening SQL Server Manager, Going to Object Explorer > Security > Logins > Right Click the login account you’re connecting to through ignition and click “Properties”. On the General tab make sure that the “default database” points to the database you’re accessing through ignition. From there, make sure the user has database read/write and table creation permissions. That fixed it for me.

1 Like