OPCUA certificate expired

I have a project am currently working on, I have created my device connection (Modbus TCP) and included the modbus address I want to view from my flow computer.
communication to flow computer and ignition server is working, but my tags cannot be viewed and the opcua certificate has an invalid date.

How to I resolve this? and view my tags as they appear from the flow computer.

Would really appreciate the support. Thanks

Stop the Ignition gateway then delete these files:

  • $IGNITION_INSTALL/data/opcua/client/security/certificates.pfx
  • $IGNITION_INSTALL/data/opcua/server/security/certificates.pfx

Start the Ignition gateway and your certificates should be valid and your default OPC UA connection should be working.


I deleted the certificates and started the gateway again but still had the issues. I am running ignition 8.0.2 but I just upgraded to 8.1 and the certificates are valid and it has a regenerate button also. Thanks for the support.

Also, do you have an idea on rectifying a faulted opcua server, I tried all the settings still no luck.

Thank you.

There should be some error message and stack trace you can get for the connection if you are in the Status area of the gateway. If you can post that here it will help to figure it out.

Thanks for the assistance, I got the solution on a page you dropped a comment on. “OPC-UA Server Authentication

1 Like