RS Logix Emulator communication with Ignition SCADA

Dear Experts,

I am new to Ignition SCADA. I want to communicate RS Logix Emulator to Ignition SCADA 8.04.
What is the procedure to set up communication between Ignition SCADA and rs Logix emulator.

Thanks & Regards
Sandeep Bakoliya

While this is possible, it is not easy. If you are just wanting to use simulated tags you may want to look into using the simulation drivers.

You can find information on these driver here:

If you really want to use the logix emulator, you have to get FactoryTalk Linx Gateway and get that installed. Then you have to configure an OPC UA connection to Factorytalk. It took me a lot of trial and error to get this to work, but it is possible. There just aren’t any documents that I have found that gives you a step by step on how to do this.

Here’s a walkthrough for Linx Gateway: Ignition Tips, Tricks, and Cheats

Also, the guys doing Flintium project stated they managed to get v32 emulate to work pointed straight to the Logix driver. I wasn’t able to get it to work, but maybe you will have better luck.

@tordvd Were you able to connect to Emulate v32 using the method in the Flintium Wiki?

I havent had the chance to try it yet. I am going to to a project for a customer in plantpax 3.x something after the summer, and will probably try it then. I probably can take a look at the alarming at the same time…

1 Like

I use VM images. I had one image with Win7x64 and installed Emulate v32. I couldn’t get things to work. I used an image with Win10x64 and installed Emulate v32. This worked using both processor versions of 30 and 32 (I didn’t try any more than those). So, not sure what the differences are. I’m guessing Windows as I have the same core software installed on both images. But, from my brief test, as long as you have Emulate 32 installed, you can still use the following processor versions… 20, 21, 21.03, 23, 24, 28, 30, 31, & 32. When you install Emulate v32, those get installed as well. Matter of fact, you may have to remove/uninstall earlier versions of Emulate to install Emulate v32. I’m assuming since 30 & 32 worked, the rest will as well.

1 Like

Is your Ignition and Rockwell software in the same VM or in different VM’s. Mine are in separate VM’s and I have not been able to get this to work. Ignition says “ReconnectWait”

Mine were separate.


Well, It’s good to hear what I’m trying should be able to work. Now I just have to figure out why it’s not working for me.

Were you able to get this working? i am only able to get the same status as you, “ReconnectWait”

It work fine. You can even create device connection using this model under OPC UA, but it has lots issue with device connection. Anyway, you do not need to connect Emulator as a device, just use OPC-DA COM you can navigate to your OPC topic, Run you RSLinx as server.


OPC-UA to RSLogix5000 Emulator? - Ignition - Inductive Automation Forum
Follow choy 's instruction

Connecting via OPC precludes easy substitution of Ignition's native Logix driver when the work is moved to production. If you can set up as described in the Flintium link, that would be preferred. Note that FactoryTalk Linx and/or RSLinx must be configured to claim local port 44818 to accept incoming connections (and the firewall opened). That isn't shown in the Flintium doc.

1 Like