Setting Up Modbus

It will poll holding register 18 on the Modbus TCP server at IP address

This is what I get

So the Modbus server does not like to keep its connection open. It allows one read and then closes the connection. It should keep the connection open for at least 30 seconds. It could be bug on their end.

If you run that same command again after a minute or 2 does it do one more successful poll?

Then try modpoll -r 18 -l 100

This will poll it every 100 msec instead of 1000 msec.

Ok this is what I got. So you think its an issue on their end? It works without disconnecting on FactoyrTalk

Try creating a new subscribed scan class in Ignition with a rate of 100 ms. Change the scan class on your tag(s) for this device to this new scan class.

I tried it. But still no luck they time out after about 8 seconds

It looks like you have a problem on both ends. The MC206X is not following the spec on disconnecting. Ignition is not handling the reconnects as well as FactoryTalk. It is really Kepware that FactoryTalk is using? One possible workaround is to try Kepware’s OPC server instead of Ignition’s. Is there a firmware upgrade available for the MC206X?

Last time I ran into this type of problem I ended up reading the flakey Modbus device with a PLC that would connect - read - disconnect with every poll.

The PLC way is what I am thinking of going. I don’t want to update the MC206X because its been running for years and don’t want that be messed up. But yea I figured there was something wrong with both ends. Thanks for helping me check things out.