1756-ENBT with OPC UA

Your help documentation indicates the PLC5 driver will work with the 1756-ENET module. Will it work with the 1756-ENBT which is far more common? I am having trouble getting this to work with a passthrough to DH+. Maybe its because its not supported?

The PLC-5 driver works with the 1756-ENBT and routing through a DHRIO module to DH+. The connection path will look like 1,6,3,60.
1 designates the backplane.
6 is the slot of the DHRIO module.
3 is the channel on the DHRIO module. (2 = channel A and 3 = channel B)
60 is the DH+ node of the PLC5. This is in octal.

What is your path architecture?

Ok, I tried this the other day. For host name I put in the address of the CTRLGX gateway. (Help documentation doesn’t reference this for CTLGX passthrough) and for the connect string I used the same as what you stated. What am I missing?

So I have a better understanding, what is the IP Address of the ENBT module, what slot is the DHRIO module in and DH+ Node Address of the PLC?

Can you drill down to the PLC-5 using Linx? It should look something like:
-, 1756-A7
[color=#FFFFFF][/color]-Backplane, 1756-A7
[color=#FFFFFF][/color]+00, 1756-L1 LOGIX5550, ControlLX
[/color]+01, 1756-ENET
___[/color]02, 1756-ENBT
[color=#FFFFFF][/color]- 06, 1756-DHRIO
[/color]+CH A, Data Highway Plus
[/color]-CH B, Data Highway plus
[/color]02, 1756-DHRIO
____[/color]60, PLC-5/20E, FUNCTEST

I don’t think we are on the same page. The 1756-ENBT is a stand alone. (No logix processor). It is used as a gateway. (similar to the old pyramid integrators). This is a very common setup in our plant. The connect string is as follows: = 00, 1756-ENBT/A - Backplane = 1756-A7/A + 02 = 1756-DHRIO/C - 03 = 1756-DHRIO/C - CHA = Datahighway Plus 11 = PLC-5/80B

So if you wanted to connect to ZL03_P51, your connection string would be 1,3,2,3

Yea tried that. It just doesn’t work.

The ControlLogix shouldn’t be needed but I’ll test it in-house just to make sure and get back to you.

I tested without the ControlLogix processor through a ENET and ENBT and both connected and browsed fine.

At this point, do the following to create a log file:

  1. In the Configure section of the Ignition Gateway, select Console.
  2. Select Levels tab then type in PLC5 and click the Set button.
  3. Select “Trace” for the level of the xopc.drivers.allenbradley.PLC5EthernetDriver and ABPLC5ConnectRequest items.
  4. Add a PLC 5 device.
  5. Email me all the wrapper.log files to support@inductiveautomation.com.

Thank you,

Files have been sent. Are you using the 1756-ENBT ip address for "hostname? That is what I am using.

Any progress on this?

Sorry for the slow response on this issue.

Question: How many data files is the PLC 5/80 B at station 11 configured for?

I looked at your log files and did some testing and the only thing I found was when I tested with a large number of data files (999) and the browse timed out. If you have a large number of data files, try increasing the Browse Timeout to say 60000 in the device configuration for the PLC 5/80 B. It will also take awhile to collect the browse data in this situation.

I still get the following error(s) when set at 60000 for browse timeout. I am using in the hostname box and have 1,3,2,11 for connect string. See pic above.

ERROR [PLC5EthernetDriver ] [13:04:38,203]: [L11Batchoff] Invalid DHRIO module channel number in path - 1,3,2,11. INFO | jvm 1 | 2010/02/09 13:04:38 | ERROR [AbstractEthernetDriver$SelectionManager] [13:04:38,203]: Error during NIO selection. INFO | jvm 1 | 2010/02/09 13:04:38 | java.lang.NullPointerException INFO | jvm 1 | 2010/02/09 13:04:38 | at com.inductiveautomation.xopc.drivers.allenbradley.requests.ABPLC5ConnectRequest.<init>(ABPLC5ConnectRequest.java:34) INFO | jvm 1 | 2010/02/09 13:04:38 | at com.inductiveautomation.xopc.drivers.allenbradley.PLC5EthernetDriver.createConnectRequests(PLC5EthernetDriver.java:110) INFO | jvm 1 | 2010/02/09 13:04:38 | at com.inductiveautomation.xopc.driver.api.AbstractEthernetDriver.channelConnectDone(AbstractEthernetDriver.java:165) INFO | jvm 1 | 2010/02/09 13:04:38 | at com.inductiveautomation.xopc.driver.api.AbstractEthernetDriver$SelectionManager.run(AbstractEthernetDriver.java:512) INFO | jvm 1 | 2010/02/09 13:04:38 | at java.lang.Thread.run(Unknown Source)

Anything new on this?