32-bit client issues Ignition 8

Working to try to get a 32 bit Windows client online with a 8.0.7 gateway. I’ve followed the steps here, but I am still getting errors.

Pretty confident I have my Java 11 JRE and JAVA_HOME set up correctly, as this is the output when I run java --version:

openjdk 11.0.6 2020-01-14
OpenJDK Runtime Environment AdoptOpenJDK (build 11.0.6+10)
OpenJDK Client VM AdoptOpenJDK (build 11.0.6+10, mixed mode)

Regardless, when I run this command in cmd.exe:

legacyClient.bat http://<gateway ip>:8088 C <ProjectName> F

I get this output:

Could Not Find C:\_curl.vbs
Could Not Find C:\launchclient.jar
Grabbing launchclient.jar
Microsoft (R) Windows Script Host Version 5.812
Copyright (C) Microsoft Corporation. All rights reserved.

Error: Could not find or load main class com.inductiveautomation.ignition.client.launch.BootstrapSwingFS
Caused by: java.lang.ClassNotFoundException: com.inductiveautomation.ignition.client.launch.BootstrapSwingFS

I’ve tried with elevated and regular command prompts, and the launchClient.bat is the file pulled from the same gateway. Anyone have any ideas of what I can try?

Got it working, had to manually download launchclient.jar from the gateway (http://[gateway ip:port]/system/launchbin/launchclient.jar), put it in the same folder as legacyClient.bat, and edit the batch file to avoid downloading launchclient.jar.

I modified legacyClient.bat from this:

    del /f "%cd%\_curl.vbs"
	del /f "%file%\launchclient.jar"

    echo Grabbing launchclient.jar
	>> "%cd%\_curl.vbs" ECHO Set objArgs = WScript.Arguments
	>> "%cd%\_curl.vbs" ECHO address = objArgs(0^)
	>> "%cd%\_curl.vbs" ECHO outputDir = objArgs(1^)
	>> "%cd%\_curl.vbs" ECHO dim xHttp: Set xHttp = CreateObject("Microsoft.XMLHTTP"^)
	>> "%cd%\_curl.vbs" ECHO dim bStrm: Set bStrm = CreateObject("Adodb.Stream"^)
	>> "%cd%\_curl.vbs" ECHO xHttp.Open "GET", address, False
	>> "%cd%\_curl.vbs" ECHO xHttp.Send
	>> "%cd%\_curl.vbs" ECHO with bStrm
	>> "%cd%\_curl.vbs" ECHO     .type = 1
	>> "%cd%\_curl.vbs" ECHO     .open
	>> "%cd%\_curl.vbs" ECHO     .write xHttp.responseBody
	>> "%cd%\_curl.vbs" ECHO     .savetofile outputDir, 2
	>> "%cd%\_curl.vbs" ECHO end with

    CScript "%cd%\_curl.vbs" %address%/system/launchbin/launchclient.jar %file%\launchclient.jar

	del /f "%cd%\_curl.vbs"
	goto launchClient

To this:

	goto launchClient

Obviously this isn’t a great solution as I don’t think it will handle updates or anything very gracefully, but it works for now. I guess the problem was trying to download launchclient.jar, and for some reason the batch file was just skipping over this and not throwing an error.

1 Like