404 Error

Yesterday we noticed that when we would browse to our IA server, port 8088, we would get the bellow error:

HTTP Status 404 -

type Status report


description The requested resource () is not available.

Apache Tomcat/6.0.18

I have tried restarting Ignition without luck. I then ran Windows updates on the server and rebooted. Still no luck.

The Wrapper.log file is attached but i don’t see anything out of the ordinary.

I’m guessing Apache is calling something that isn’t there but I’m not sure where to look to see what is being called.

Thoughts? Thank you
wrapper.log (11.1 KB)

I would first check to to make sure your Java installation isn’t hosed and it’s still actually on the path. To do this just open up a command prompt then on the command line enter:

java -version

If you don’t see something like the following I would try re-installing java.

java version "1.6.0_26 Java(TM) SE Runtime .........
If that doesn’t work then you’ll probably want to give a call into support so we can take a look at your system to see if we can figure out what’s going on.

It is most likely due to a corrupted xml file in Ignition’s install directory. Here are the files to check out:

C:\Program Files\Inductive Automation\Ignition\tomcat\webapps\ctx0\WEB-INF\web.xml
C:\Program Files\Inductive Automation\Ignition\tomcat\webapps\ROOT\WEB-INF\web.xml
C:\Program Files\Inductive Automation\Ignition\contexts\main\gateway.xml
C:\Program Files\Inductive Automation\Ignition\contexts\main\cluster.xml
C:\Program Files\Inductive Automation\Ignition\config.xml

Take a look at any one of those and if they look like binary rather than valid xml you need to replace the file. In most cases we include a clean version of the file filename.xml_clean that you can copy and paste and rename. Once you do that restart Ignition and it should be ok.

Thank you both for the info. Travis was correct it was a corrupted xml.

Thanks for the help


In case it helps anyone, in linux (ubuntu at least), “java --version” doesn’t work. You need “java -version”.

I’m running 7.5.7 and getting a 404 error as well. I can see /usr/local/bin/ignition/tomcat/webapps/ROOT/WEB-INF/web.xml and web.xml_clean, but have these other xml files been deprecated or are they located somewhere else in linux?

You dug up a 2-year old thread. These files are now in different places.


There is no more cluster.xml, but there may be a redundancy.xml

I have the same problem. How can i repair .xml?

In most cases we include a clean version of the file filename.xml_clean that you can copy and paste and rename. Once you do that restart Ignition and it should be ok.

We have a version install that has a corrupted ctx0\WEB-INF\web.xml and no web.xml_clean in that directory. All other files Travis listed in his June 2011 post are accountable. Looking for a link to copy of all the xml and xml_clean files for this version.

C:\Program Files\Inductive Automation\Ignition\tomcat\webapps\ctx0\WEB-INF\web.xml

You might want to email support. IA’s public version archive doesn’t go back that far.

Try replacing it with the attached.

web.xml (2.7 KB)

Thanks Kevin, after replacing the web.xml file:

  • the application startup link launches the java/ignition startup splash screens but the “Error Launching” “error 404” comes up and the connection is never established. Never got this far with the corrupt xml…
  • browser still fails to open gateway at either localhost:8088 or
    I would like to do a fresh install - can you send me a link to download

Do you know if you have a 32-bit or 64-bit version installed?

32 bit, also if I send you the license.ipl can you extract the license keys or is there another way to get the licenses without the gateway?

I can give you access to the PC over google remote desktop as well if you have time

You can just copy the license.ipl file to your desktop and then put it back in place after you reinstall. As long as your underlying hardware hasn’t changed it will still work.

If you want remote support for any of this you’ll need to wait and call on Monday to work with a support engineer. Or pay for emergency after hours support if you need it today.

Here’s a link to the installer: https://www.dropbox.com/s/d3hixcb4o2lkttk/Ignition-7.2.3-windows-installer.exe?dl=0

Do make sure you have a backup or copy of the internal DB or something in case any of this goes sideways.

will do - Thxs again