7.1.8 issue with leased mode?

Did anything change with the leased mode in 7.1.8? I was running 7.1.8beta and this seemed to work fine. Ever since upgrading to 7.1.8 my leased mode class is dropping to the slow rate when it should not. Screens with those tags on them are active yet they are dropping to the slow rate. I checked the OPC Connections status page to confirm. The writes still seem to go through quickly even though the subscription rate is slow. When I press a button the tag in my PLC comes on right away, but the indicators are where you really see the issue.


Do you know which beta number were you running exactly? There haven’t been any changes directly to leased scan classes since August 3rd, but if we can narrow down the window perhaps there’s something somewhere else that changed and is affecting it.

Also, what is your SQLTags setup like? That is, is it just the internal provider, or is it an external provider, multiple providers, etc.?


I am not sure of the beta version. I downloaded it on 11/18 though if that helps. I am just using the internal tag provider.

It definitely looks like something else causing my issue. I changed the scan class to direct at 250ms. All the tags are subscribed properly in the OPC Connection status. However I still have the same delay with my PB indicators. It takes around 8 seconds from when my PLC tag is set before the object on the screen changes state.

Well, you can at least narrow down what your scan classes are doing for certain by logging into the gateway, and going to “Console>Execution”. Look for the “sqltags scanclasses [default]” group. That will have the execution statistics for your scan classes. Take a look at the throughputs, executions, etc.- do they look correct? Using direct scan classes this should all be straight forward.

If everything is ok there, the problem is further down the line with values not coming in from OPC quickly enough. Let me know how those stats look and we’ll go from there.


I checked the execution in the console and it showed a delay of 10s for my scan class. I then went to the scan class editor and sure enough the direct mode rate was set to 10s. This used to be my slow mode rate when I had it in leased mode. Somehow I did not set it correctly when I changed it to direct. After I set it to 250ms everything started working fine. I tried setting it back to leased mode and it worked fine as well. I have no idea what originally happened with the leased mode. Somehow it was just stuck in the slow mode. After changing the mode it is fine now. I am going to leave it in direct anyway. Until 7.2 comes out the leased mode does not help me much anyway the way my classes are set up (only if the client is closed).

Ok, I’m glad to hear that that things are in line, at least for now. Yes, 7.2 will be much better for leasing.