7.6 Auto Schedule Start Problems

Hey guys,

I’m having a problem with schedules not auto starting after the upgrade to 7.6. The last couple of days I’ve had some lines that will not auto start schedules. I also can not manually start the schedules because the schedule controller can not find the schedules that were entered, which I believe is the root of the problem.

It seems that the schedule controller is having trouble finding schedules that were entered the day before. Yesterday when I entered the schedules for today I could pick those schedules in the line schedule selector and today those schedules are not selectable (they do not appear in the drop down). However, if I go to the schedule entry screen all of the schedules that I entered are there for every line. I went through the console and there are no error that I can see that have anything to do with the OEE/downtime module. Is there something else that I can check or is this a known issue? I would at least like to be able to start the entered schedules manually, but I can’t even do that. If you have any ideas let me know. Thanks!

Hi,
I will need to mock that up here and see what the issue is.
Thanks for the all the info.
Regards,

Hi,
I cannot re-produce the issue here with 7.6.
My lines are auto-starting the entered schedules and I can see un-ran schedules from previous days.
Once a schedule is ran and ended it will not be available for re-selection in the drop down.

Ok, is there anything I can look for in the logs or in the database to see if, when or how the run was started/ended? I see auto start entries in the logs for the lines that actually did start, but not for the ones that didn’t. Here’s the schedule entries and what I can pick in the schedules run selector:




If you look at the analysis window you can get a list of all the runs for a specified date range. If you use a “Run” provider, compare by “Run” and select the “Schedule Production Start” and Actual Production Start" you would see the runs and when they started. There are other datapoints to choose from that will give you more information.

Are you entering the schedules via scripting? If so, then you might need to reset the schedule cache by using this script:

system.schedule.resetScheduleCache(<line path> )

According to the analysis screen, none of the runs that did not auto start are scheduled and did not autostart:


I tried putting the cache reset code on a button but that didn’t do anything. It still won’t find the schedule entries for today or yesterday for a couple of the lines.

EDIT:

I also looked in the schedule database table and it does look like there are datetimes entered in for the start, but for some reason it doesn’t think they are started:


And you are certain those lines are still set to auto start in the production model?

Yep, that’s the first thing I checked. :stuck_out_tongue:

Please export the log file and attach it here.

I’m trying to determine the link between the runs not starting and not being able to see the scheduled runs.
When did this start?
Is it only affecting certain lines?
Do you have another copy of the project active in the gateway projects?

Ok, I have attached the log file.

Looks like it started on Monday for one of the lines and then on Tuesday for the other.

Yes, I have 3 lines and two are not auto starting, or I can’t select the scheduled run for those two lines.

No, I only have 1 of this project active on my gateway. I do have other projects on the gateway, but none of them use the production stuff and the production model is disabled on all other projects.

wrapper20130515.log (619 KB)

Actually, I need the file (logs.bin.gz) from export link on the gateway console page.

Ahhh, ok here you go. I had to change the file extension to .zip because it would not allow me to upload a .bin file. You’ll have to change it back:

20130515logs.zip (536 KB)

This morning one of the lines that was having a problem started up fine and the line that’s been good (clean side) did not start and I can’t see the schedule entry for today. The 3rd line (Stick Pit) is still not working either. So, now it seems to be random. I’ll include another export with the data from this morning.

logs20130516.bin.gz (537 KB)

OK, let’s see if the online session we had today fixes the issue. The runs were being started but it appears the line was not notified of the start. I have not seen this before.

Regards.

Hey Pete,

The same thing happened this morning. The clean side started ok but the wet side and stick pit lines did not. Looks like the same issue. FYI.

Hi Doug,
The 7.6 RC2 has some fixes on the alarm errors we were seeing. They could possibly be tying up memory.
Would it be possible for you to update?

-Pete Low

Yeah, I was going to update the servers tomorrow to try and fix some of the other issues that I am seeing with the alarming stuff. I can see if that makes a difference on Monday. I looked in the database tables that you were looking in yesterday and there are a run id’s entered in for the lines that aren’t actually running. Will I have to manually put End dates in for those runs like you did yesterday?


Yes, I would so that we can see any new changes easier.

-Pete Low

Hey Pete,

I upgraded to 7.6 RC3 over the weekend. I also didn’t add the schedules for Monday until I upgraded the servers. It still did not fix the issue however, though 2 lines started today instead of just 1. The 3rd line is still not reporting as started. It’s also putting in a double run entry for one of the lines still as well, it also did this on Friday and which line gets the double run is not always the same. Seems to be random. FYI.


Hey Pete,

FYI, restarting the master node did seem to fix the issue. Everything started up without incident this morning. Thanks for your help!