[7.7.2] Alarming Override in an UDT does not work


Since 7.7.2, I can not override the alarming section of a UDT-instance. Clicking on “Apply” or “OK” does not save the overridding anymore.
I tried the same operation on a 7.7.1 and it does work.

[li]Create a UDT[/li]
[li]Create a tag in UDT[/li]
[li]Create an alarm on this tag[/li]
[li]Instanciate the UDT[/li]
[li]Double click an add a new alarm or override the existing one[/li]
[li]Click on “Apply” or “OK”[/li]
[li]Check that changes have not been saved.[/li][/ol]

Am I doing something wrong ?


I just updated to 7.7.2 today, after reading your post I went and checked the alarms on my UDT’s. It did indeed over-write the overrides back to the defaults.

This is a known issue that has been fixed for 7.7.3-rc1. Sorry for the inconvenience.

When will 7.7.3 be released? I have had a ton of issues after the 7.7.1 and 7.7.2 upgrade. thx


When I upgraded yesterday, this bug broke all my overrides too (100s of alarms). When this is fixed in 7.7.3 will my overrides start working again or will I have to edit the entire project?

Any date yet for the release of 7.7.3? We too are having major UDT related alarming issues.

Rolled back to 7.5. In a production environment I need to have my alarms working properly. That was a painful 24 hours. :cry:

Wow, thank you for posting this, I was trying to come up with a justification to upgrade to 7.7.2 for my client and we’d have an impossible mess if all our alarms broke.

I’ll be testing 7.7.3 rc 1 next week. I’ll post on how it goes.

I’ve made some test in my dev environment and found that version 7.7.2 doesn’t show the overridden property but the change works.
If you override for example the setpoint, you cannot see the overridden value but it’s then applied.
This can be good but also more confusing.

I will test 7.7.3 rc1

NOTE: v7.7.2 rc1 was working properly

Upgrading to 7.7.3 rc 1 sort of worked. Overrides now stick when applied to UDTs :slight_smile: . However, all my alerting overrides for UDTs were lost (1000s) and would need to be rebuilt :frowning: . So, I rolled back to 7.5.12 again and am now setting up a test machine to see if we can figure how to solve this.

To be clear, this was an upgrade from 7.5.12 -> 7.7.3rc1? I’ll try and mock something up.

I did a stepwise upgrade to 7.6.7 before going on to 7.7.3 rc 1. When that didn’t work, I tried restoring the project I backed up before I started the upgrade to 7.6.7. That didn’t work either.