7.7.2 - Data Type Inheritance Issue

I have a user-defined data type that includes alarming. I have other user-defined types that include instances of the alarm type. I renamed the alarm extension in the parent type. In most instances the rename inherited correctly. In at least one instance, the user defined type definition now shows two alarms on the tag, one with the original name and configuration and one with the new name. Both are shown as inherited and cannot be deleted.

Is there any way to reset the inheritance so the definition updates correctly? This may be related to the issue where we are unable to override alarm characteristics in user-defined types.

I have tried exporting the type definition to xml. I saw the “extra” alarm extension in the file. I deleted it from the xml and tried importing the definition, but it made no difference.


I think 7.7.2 is generally buggy with respect to alarming and user defined data types. I can’t reliably add alarming to tags in instances of UDTs. I click the plus symbol, fill out the info for the alarm and click “apply.” The tree re-builds and when you click on the tag within the datatype structure the alarm you just added has disappeared. When will 7.7.3 be released?