7.9.10 Upgrade - Scale Issues

I just upgraded the gateway to version 7.9.10 and when I launch a client the scaling is off and it looks like total crap. Im getting a blocky pixel look, and the client isn’t fully visible in the window. Any ideas on the culprit?

What OS are you launching the client on? Are you using the new client launcher downloaded from the 7.9.10 gateway or something else? What resolution monitor and DPI settings are you using?

windows 10, I downloaded a new client launcher from the 7.9.10 gateway. dual monitors, one a laptop. They are both 1920x1080. DPI? not sure. The clients look good on my 27 inch extended screen, and like crap on my 14 inch laptop screen. Pictures and icons seem to be the most affected. everything in the design looks larger than normal, I can’t even see the entire client screen without zooming out. plus I couldn’t launch the designer with “create shortcut” box checked. I had to uncheck it to even launch it. It seems that everything is a little bit larger than it should be.

Also, I downloaded the NCL on the gateway which is Windows server 2008 R2, and it ran perfect. Everything looked as it should with no issues.

If you launch a client/designer through the webstart/JNLP links, is the scaling still off? The client launchers in 7.9.10 have an embedded JRE, which we did test with different DPI/scaling combinations on Windows, but that seems the most likely cause of this issue - if you use webstart, you will still use your system’s JRE and should get the scaling you’re used to.

If you prefer the client launchers, you can also access the old client launcher executables in the install directory, under /lib/core/launch. We’re going to do some more research into this internally.

The webstarts look like they should, so you are probably correct in your assessment. I still wonder why I cannot run the designer from NCL with “create desktop icon” checked. I can only launch it with it unchecked. I will look into using an older NCL for now.

I can confirm this problem. 7.9.9 with client launcher looked good. 7.9.10 with webstart looks good. 7.9.10 with client launcher has significant scaling problems.

Is this specifically on Windows (10?) with a high-DPI monitor? What’s the OS’s scale factor for that monitor? What’s the actual screen resolution?

1920x1080, 1920x1080

My client is set to start up at 1750x1000. When I start it with the client launcher it spans 2 screens (part of the second screen). Looks like 2200x1100??? When I maximize it to a single screen (1920x1080), the docked windows take up the majority of the space (they don’t scale properly)

When running on Linux VM (single screen) using the new client launcher, the scaling looks fine. Fonts are terrible.

This approach doesn’t work. It starts the launcher but when I select the client. It never launches.

@weertske is your setup a laptop + 2x 1080p monitors or just 2 monitors and a desktop? Is the laptop screen high dpi?

I’ve tested it on two different machines. 1st machine is a laptop with a 1920x1080 screen plus a remote 1920x1080 screen
2nd machine was a Surface Pro tablet with standard resolution (2738x1824). Both scale incorrectly.

I upgraded to 7.9.10 this morning on windows 10. My main dev monitor is 4K.

Following these steps helped make things clearer: Windows 10 HiDPI Scaling

I actually liked it in native 4K, with small icons, most of my work at the minute is creating scripts and I just Ctrl + mouse scroll as necessary

Hi @weertske,

I was hoping you could provide me with some more info and maybe a screenshot? Here is what would be helpful:

  1. Which version of windows you are running on.
  2. Your DPI scaling. This is under your Display settings, specifically “scaling”. It would be useful to know the scaling for each monitor
  3. a screenshot of your designer open with the scaling issues present that you are seeing.

As a workaround, could you try something for me and let me know if it works for you:

  1. Could you use the new Client Launcher and create a desktop shortcut (or use one that you previously created from the new Client Launcher)
  2. right click the shortcut and select properties.
  3. append -Dsun.java2d.uiScale=1.0 to the “target” field.
  4. Launch the designer or vision client.

This argument will override the internal scaling and set it to some percent in floating point format. you can change the value “1.0” (which means 100%) to any other value to meet your needs. for example, change it to 2.0 which will scale the program to 200%.

I hope that helps and i look forward to hearing back from you.

Thanks,
Jonathan C.

1 Like

I replied privately to this question but everyone needs to see my answer:

Jonathan,

  1. Windows 10

  2. 125% on this laptop. I am going to guess 150% on the Surface tablet (don’t have it with me right now)

  3. The scaling setting was the cause of the issue as the version with the scaling set at 100% looks correct. Your workaround fixes the problem. What is your plan to address this issue?

I have the same problem in the clients, some solution for that? Upgrade from 7.9 to 8.1

I also still see this behavior in 8.1. I’m using anchored layout for all my components. The suggestions laid out in @jcoffman’s post above fix the issue for the most part, however you no longer need to apply the java argument to the shortcut file itself. Instead, you can edit the Vision client launch settings like this:

image

A side note is that this solution works both for windows scaling issues (e.g. monitor running at 150% scaling within Windows) and project upscaling (running a 1080p project on a 4k monitor). You’ll just need to find the resolution ratio between project/monitor and adjust the 1.0 accordingly. E.g. 1080p to 1440p = 1440/1080=1.3333, meaning your JVM argument would be -Dsun.java2d.uiScale=1.3333. Now a 1080p anchored-layout project will properly display on a 100% scaled 1440p monitor.

There were some upscaling artifacts in my experiences, but nothing show-stopping.

2 Likes