8.0.13 Client Launcher Not installing Apps

Recently updated the gateway to 8.0.13 and cannot use the client launcher to install apps.

My work around was to reinstall the client launcher from an older gateway 8.0.12 which then was able to install the icon, app and launch the app.

Bug?

Hi @jcaudle,

When you say install apps, do you mean create a shortcut on the desktop? What OS are you on? anything in the launchers log? it would be in .ignition/clientlauncher-data

Thanks,
Jonathan C

JCaudle and I are working on this issue together. The log says something about not being able to connect with the back up gateway but then says that launching will continue. As far as the user interface is concerned it shows the connecting window for several seconds which then disappears and nothing happens. No error message no zulu process no nothing. As soon as I install the client launcher from the 12 gateway it works like a charm.

I think I have found the cause, but not sure how to remedy it. Both our main and redundant gateways are on servers with two networks, one that is a business network, accessible to anyone in the company on the network, and one that is connected to plant equipment (PLCs, etc.), that is accessible to only a few people.

If I try to open the designer or a client when I am connected to both networks, it opens with no problem. If I disconnect from the plant network, I get the connecting window for a few seconds, then it disappears. The log then lists the following error that indicates it can’t find the backup gateway on the plant network:

A Communication error occurred when attempted to communicate with the backup gateway ‘http://#.#.#.#:8088’. Launching will continue, but no certificate checking can be performed while it is down

JCaudle and MQuinn work at the same company as me, but they don’t have access to the plant network. I have tried this on other clients that do not have plant network access, with the same result. This was not an issue prior to 8.0.13.

Hi everyone,

I get the same error:

Our server is on 8.0.13 and I am using the 8.0.13 client launcher. We have a backup node but still some performance issues with it, so we shut down our backup server. And when it is down, I cannot launch any project.
But all my colleagues who still use the 8.0.10 client launcher can launch projects. Do you know what the problem is and how to fix this?

At the end you can find the complete log output after trying to launch a project.

Thanks for your help,
Markus

INFO  [ClientLauncher                ] [2020/07/24 10:20:47]: Set initial logging level to INFO
INFO  [ClientLauncher                ] [2020/07/24 10:20:47]: Updating logging level to INFO
INFO  [GatewayConnect                ] [2020/07/24 10:20:48]: Attempting to connect to gateway http://deapp020:80...
WARN  [CertificateCheckService       ] [2020/07/24 10:20:50]: A Communication error occurred when attempted to communicate with the backup gateway 'http://10.28.16.21:80'. Launching will continue, but no certificate checking can be performed while it is down
java.net.ConnectException: Connection refused: connect
    at java.base/java.net.PlainSocketImpl.waitForConnect(Native Method)
    at java.base/java.net.PlainSocketImpl.socketConnect(Unknown Source)
    at java.base/java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
    at java.base/java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
    at java.base/java.net.AbstractPlainSocketImpl.connect(Unknown Source)
    at java.base/java.net.Socket.connect(Unknown Source)
    at java.base/sun.net.NetworkClient.doConnect(Unknown Source)
    at java.base/sun.net.www.http.HttpClient.openServer(Unknown Source)
    at java.base/sun.net.www.http.HttpClient.openServer(Unknown Source)
    at java.base/sun.net.www.http.HttpClient.<init>(Unknown Source)
    at java.base/sun.net.www.http.HttpClient.New(Unknown Source)
    at java.base/sun.net.www.http.HttpClient.New(Unknown Source)
    at java.base/sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source)
    at java.base/sun.net.www.protocol.http.HttpURLConnection.plainConnect0(Unknown Source)
    at java.base/sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source)
    at java.base/sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source)
    at java.base/sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
    at java.base/sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
    at java.base/java.net.HttpURLConnection.getResponseCode(Unknown Source)
    at com.inductiveautomation.ignition.launcher.common.utils.GatewayCommUtil.getGatewayConnection(GatewayCommUtil.java:181)
    at com.inductiveautomation.ignition.launcher.common.utils.GatewayCommUtil.getGatewayConnection(GatewayCommUtil.java:113)
    at com.inductiveautomation.ignition.launcher.common.utils.GatewayCommUtil.getGatewayRawResponse(GatewayCommUtil.java:263)
    at com.inductiveautomation.ignition.launcher.common.utils.GatewayCommUtil.getGatewayInfo(GatewayCommUtil.java:396)
    at com.inductiveautomation.ignition.launcher.common.utils.CertificateCheckService.lambda$checkGateway$4(CertificateCheckService.java:172)
    at com.inductiveautomation.ignition.launcher.common.utils.SimpleService$1.call(SimpleService.java:23)
    at javafx.concurrent.Task$TaskCallable.call(Task.java:1425)
    at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
    at javafx.concurrent.Service.lambda$executeTask$6(Service.java:725)
    at java.base/java.security.AccessController.doPrivileged(Native Method)
    at javafx.concurrent.Service.lambda$executeTask$7(Service.java:724)
    at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.base/java.lang.Thread.run(Unknown Source)

I have an open ticket for this. Feedback I’ve received so far indicates it may be a SSL issue.