8.1 -- Designer hanging up on launch/slow

After upgrading from 8.0.14 to 8.1, I’m having some trouble opening and using the designer. However, these problems only happen when I’m trying to use the designer on any device other than the host machine.

Everything works up until I’ve entered my credentials and opened a project. The launcher hangs up on the "Starting module: Perspective..." message until I either forcibly close it or wait it out for ~15 minutes. After that, the designer launches, but my mouse cursor constantly shows as loading. The performance of the designer is poor, and none of the Perspective resources can be viewed, as they fail to deserialize and consequently time out.

I also tried opening a new blank project, but the same issues occur while not on the host.

I’ve inspected the logs while this has occurred, and there are dozens of the top SystemPropertiesRecord warning and a few of the bottom warning:

Again, these problems only occur when not using the host machine. What’s going on, and is there a way to fix it?

Thanks!

Those warnings seem to suggest that the gateway is unable to read the config page and home page security level permissions from the general security settings stored in the internal DB for some reason, and are falling back to their default values (Administrator role required for config page, unrestricted access for the Home Page). What values are stored in the ConfigPermissions and HomePagePermissions columns of the lone row in the SysProps table? Maybe something went wrong during upgrade, though it is not immediately clear to me how that is related to the slow designer connection issue…

Both values are nulls, which explains the logger warnings I posted. It seems this is a tangential problem since it continues logging the SystemPropertiesRecord warnings even when not opening/running the designer.

I delved into logs some more, but I can’t find anything of note when starting up the designer. Maybe there’s something that I’m missing? Here’s the logs from all of today, including from doing the upgrade. I’m stumped.

wrapper.zip (138.8 KB)

I’ve looked through your log file, but I cannot find anything that would explain why the designer would be slow when connecting from remote machines. I do see a lot of exceptions in the log, some of it is benign spam, others may be something to look into, such as disabled DB connections. I have logged a couple of tickets internally for bugs on our end (including the java.util.MissingFormatArgumentException: Format specifier '%s' error).

What’s strange is that I’d expect the following format of messages to be logged on start of 8.1.0 for the first time (indicating that your role-based system permissions be upgraded to security levels) yet I do not see them (almost as if the internal DB has been upgraded to 8.1.0 before):

%d rows affected
Upgrading setting '%s' with value '%s' to '%s' with value '%s'

Do you have a row in the SRFEATURES IDB table with value 8.1-roles-to-security-level-permissions-update in column featurekey?

Back to the slow Designer issue: Have you tried removing the Perspective module temporarily to see if the designer starts up fast? That would at least help narrow down the problem to something with the Perspective module…

Do you have a row in the SRFEATURES IDB table with value 8.1-roles-to-security-level-permissions-update in column featurekey ?

Yes, I do.

Have you tried removing the Perspective module temporarily to see if the designer starts up fast?

Done. The designer works properly and quickly after removing the Perspective module, both on host and other machines.

(almost as if the internal DB has been upgraded to 8.1.0 before)

That might be the root of some of the issues. We were initially on an 8.0.13 nightly version. The first go, I tried directly upgrading from that nightly to 8.1, which resulted in a huge mess. After I realized that wasn’t the way to go, I upgraded first to 8.0.14 release, then to 8.1 as previously described. I swear I ran the uninstaller after the first go, but maybe I didn’t, or I missed another step in the uninstallation process.

We’re trying to figure out the safest way to upgrade prod, so we’re trying to mimic the process on this test server. I might try blowing away this configuration and starting over with the initial nightly version. Is that okay, or would it be beneficial for you guys to keep and continue troubleshooting this for a while?

Before you blow away the system, someone internally recommended re-installing the Perspective module and adding the following two JVM args to your Designer launcher for the Gateway you are having issues with:

-Djxbrowser.logging.level=ALL
-Djxbrowser.logging.file=/path/to/some/dir/jxbrowser.log

Then reproduce the slow designer issue, and once complete, send us the jx browser log file. We just want to rule out that JX Browser is not having any issues here.

Probably wouldn’t hurt to take gateway backups of the system before the upgrade and again as it stands after the upgrade and send those over for us to inspect. Not sure if we’ll be able to find much more, but we could try and reproduce the issue locally by restoring those backups.

It sounds to me like something may have gone wrong with the steps taken to upgrade, then rollback, then upgrade once more. That could explain the permissions issue spamming the logs, and maybe it has something to do with the slow designer issue, but I’m not certain.

1 Like

I reinstalled the Perspective module, but upon launching the designer, although the “Launching Perspective…” text appeared, the module did not appear (and thus I was unable to replicate the behavior). I then restarted the gateway to get similar results. Curiously, if I’m on the host machine and open the designer targeted at localhost:8088, the module is there; if I use the IP address instead (either from host or elsewhere), then the module is not there. I double-checked the IP address because I thought I had gone mad.

Furthermore, after the gateway restart, I am unable to log in to the gateway. Clicking on log-in refreshes the screen without actually showing the log-in text field. The logs show that it’s erroring out with the IdP requests. Here’s a log snippet in case it’s useful/interesting wrapper(2).txt (36.6 KB)

I suppose all that’s left to do is call it FUBAR and start from the beginning since I can’t get into the gateway to take a backup. If I have the same issue again, I’ll update this topic. Thanks for your help and your time, @jspecht! It is much appreciated.

Hmmm… yeah not sure how you got into that state. Looking at the log snippet you uploaded, seems like your system IdP is now pointing to an IdP which no longer exists. You could do a GCU password reset and gateway restart to get back into the gateway web interface, but I understand the desire to start from scratch, especially if you believe some of the upgrade steps went awry.

As far as the behavior difference between using an IP vs a host name, or connecting over localhost vs a remote host, might be good to call support and have them take a good look at your setup to see what could be going wrong (if it happens after re-installing / re-upgrading).

Bad news: problem presented itself again even after completely clean install/upgrade(s), meaning the issues probably don’t stem from taking the wrong steps to upgrade. Silver lining: got the jxbrowser logs as requested: jxbrowser.log (46.5 KB)

I tried taking two different paths to getting to 8.1, including:

  • 8.0.13 nightly → 8.0.14 → 8.0.16 → 8.1, and
  • 8.0.13 nightly → 8.0.14 → 8.1

but the same designer/Perspective issues have persisted upon getting to 8.1.

I’ve now also DMed you before and after gateway backups, which should hopefully reproduce the problems. If I need to open a support ticket or do something else instead, please let me know.

Thanks again.

Did someone find a root cause for that? I experience the same behaviour on two of my gateways and it started totally randomly. No upgrade, no new project or something. I don’t have new log entries or something that could point me to a direction.

Hi @BluegelMarius

I would recommend reaching out to support about this to determine the cause as it sounds a bit different than these issues and experiencing this without upgrades, new projects, or new modules (assuming) it might be something else going on with your system.

Hi! Reached out to the support multiple times but they had not been able to find the root cause. After a few months I found that the issue is realted to the number of User Roles that you define in the Role Search Filter (only an issue when using an Active Directory User Source). I resolved the issue by restricting the amount of roles to display to less than 50.