8.1 Vision client Launcher installation issues on 64bit Raspberry Pi

I'm currently running into issues trying to get Vision Client to run on my Raspberry Pi. I have it running the latest version of the 64bit Raspbian OS. Downloaded the Client Launcher from my Gateway on the primary computer, downloaded as a .tar file. I unzipped that and have been unable to get it to actually execute. What I have done and tried so far:

  • I have Java OpenJDK v.11 installed
  • it's stored in my "usr/local/ignition" folder
  • everything has execute permissions
  • if I try executing the (.desktop) Launcher file by double clicking it does nothing
  • executing the (.desktop) Launcher file by command line gives errors
  • using the "sudo ./name start" on the .sh file in the app folder does nothing
  • using the "sudo ./name start" on the .jav file in the app folder errors out

Any suggestions on what to do to move forward?

Client launchers do not work on RPis, even the 64 bit ones, you have to bootstrap it with legacyClient.sh
Version 8 32-bit vision clients - Ignition - Inductive Automation Forum

2 Likes

JavaFX is not available on most ARM cpus, so anything in Ignition that depends on it will fail. The legacy launcher doesn't need javafx itself, and can therefore launch any client that also doesn't need javafx. (IIRC, you cannot use the JxBrowser component without javafx.)

2 Likes

IIRC Liberica claims to support JavaFX. I've not had the opportunity to try it yet.
EDIT: To clarify, I use Liberica on my Pi's but haven't tried JavaFX things yet.

2 Likes