AB Micro820 Modbus Mapping issues

Just getting into Ignition and I'm having a hard time getting these units working over the Modbus.
I've done a fair amount of reading here, trying all sorts of different settings suggested.
In the Config section of Ignition I get "connected" but any time I setup a tag in the Designer it reports as "Bad".

The current test setup is as such:
Laptop with Ignition (trial mode) direct connected (ethernet) to the ethernet port on the 820.
Modbus enabled on the 820, bool variable mapped to address 000001.
Device [test] setup in ignition (config, opcua,device connections) Modbus RTU over TCP.
Hostname set to IP of 820.
Port at default (502)
Reverse word order checked
Span Gaps unchecked (default is checked)
Tag setup in designer
DataType: Boolean
Item Path: [test]C1 (shows bad)

Tried setting up Addresses in the ignition config
Prefix: DO Start:1 End:2 UnitID:0 ModbusType:Coil Address:1
TagSetup in designer
DataType: Boolean
Item Path: ns=1;s=[test]DO1 (and DO2) only shows bad

I've tried all sorts of checking and unchecking connection settings in the advanced setup (ignition config) all has shown the same "Bad" tag status. Tried multiple different types of data (Byte, int, short, bool, etc) all show "Bad" tag status.

I'm lost here..... Can someone walk me through how to set one tag up? Apparently I need it spelled out like a complete idiot, as I haven't been able to get it from reading other threads here (where people have said it's done and easy)


You probably need the unit number in your addresses. Like [test]1.C1 and [test]1.DO1. Ignition uses unit #0 by default.

It's been a while since I last used a Micro820 but if I remember correctly it uses Modbus TCP, so you should have that selected in your device config (rather than Modbus RTU)


I can't believe I didn't see that option to try.

I saw the RTU option and knew I wasn't direct connected to serial.... Must have skipped the TCP only option somehow.....

Thanks for helping the idiot here.