AB PowerMonitor 1000 - Cannot read data (OPC)

Has anyone successfully read data from an AB PowerMonitor 1000?

I have tried using Ignitions SLC500 OPC-UA driver and manually entering a PowerMonitor data address into the Tags OPC Server and OPC Item Path fields, but no success.

I have created an OPC topic using RSLinx Gateway. I can view the tag values using the RSI OPC Test Client that comes with RSLinx. I have added the RSLinxOPC to the Ignition OPC Connections Servers. I can open Ignitions quick client and brows the address. HOWEVER, when I try to read an address value with Quick Client (F10:2 for example), it say’s:
"Read Completed [RSLinxOPC] [PMEthIP] F10:2
Status: OPERATION_FAILED
Value: NULL
Quality: [OPERATION_FAILED] null "

Any pointers would be greatly appreciated.

Thank you

Interesting. Consider trying Ignition’s Ethernet PLC-5 driver instead.

Thank you for the suggestion Phil. Yes I had tried this as well as trying the MircoLogix setting.

It’s strange that even the RSLinx OPC not working in Ignition either. It is running on an active license in Gateway mode on the Ignition Gateway server.

I think I solved it. I disabled processor browse in the advanced settings section of the AB SLC 5/05 Ethernet Config.
Shall continue some testing and report back.

Hi! I was just about to try this. Know it was a long time ago, but were you ever able to access the Powermonitor 1000 tags by chance? Thanks either way.

Drew
Wow, I forgot all about this. YES I was successfully able to add PM1000 (Ethernet) tags using the SLC 5/05 driver. The key is to “Show advanced properties” and select “Disable Processor Browse”.
Example:
My OPCUA device for the PM1000 was “PowerMonitor1000”
Tag OPC Item Path: ns=1;s=[PowerMonitor1000]F24:7
Attached is an example of my UDT structures for the PM1000
Hope it helps.

PM1000_UDT.json (7.0 KB)

1 Like

Thanks for the reply! I will post to the forum how it goes.
Update: I kept getting “Connecting” then “Disconnected” trying to use the AB SLC driver. So I tried using the Modbus TCP driver and that seems to be working well. I had trouble creating the OPC Item Path manually, so I used the Modbus Address Configuration on the Gateway to create the tags and this seemed to work well.

Hi @drew.bell, I had success by using the MicroLogix driver. You still need to ‘Disable Processor Browse’ though as @HenryScalfo suggested.

Thanks Matthew. I disabled my Modbus TCP version of the device and added a new device using the Micrologix driver. It connected, but my tag status is showing “bad”. I think I have a correct OPC Item path. ns=1;s=[708-ChassisSludgePowerMonMicro]F9:3 - with my OPC Item name in the brackets. Were you getting “Connected: Protocol: PCCC” for the gateway device status. I suspect this is maybe not the protocol I want? I think I’m going to try going down the Modbus TCP fork in the road until I stumble. I’m still working on getting some CTs installed and figure out what we can learn from the PowerMonitor.

You still haven’t said that you’ve disabled processor browse in your attempts. Did you?