Abnormally datetime timezone change when inserting to database

Hi! I'm having some trouble when inserting a datetime into database. I'm running a runPrepStatement over an insert query and when i log the data i'm persisting it appears to be OK, but, when its persisted timezone seems to change. I've setted project timezone to different timezones and nothing changes, neither the timezone of the project nor the timezone of the persisted date. I've tried to force select bringing the date at time zone 'utc' and this crashes... I assume the best way is to store data in utc but no idea of how can i do this if project propperties does nothing and its hard to import third party libraries such as pytz so i can "play" with timezones on python code.
Regards, Jorge

EDIT: The problem was ignition doesn not work well with python datetimes because of milliseconds. I tried using system.date.now() instead of datetime.now() and now all works fine with sql server datetime column type.

i would store it as timestamp

I'm working with sqlserver, so, you mean create a column as bigint and storing date in millis? Sounds well i'll try

no nono sql has timestamp columns too right? It looks like a big number, but its a timestamp

sql server's timestamp is... not a datetime data type. The naming is non-standard. It was used for row versioning, but they introduced rowversion to avoid the confusion. Don't use timestamps with sql server.

What the type of your column ?

For reference, here are sql server's date and time data types:

But, as I'm not storing values previous to 1970 then i assume bigint is also a good choice

timestamp is for values after 1970