Accessing Property Change Script

I inherited a project that utilizes a table posting ticketing information.
I have successfully altered the property "data" binding (database query) changing the information that gets posted to the table. However, when active in preview mode, an error appears after selecting a row.

**Error running property change script on Traceback (most recent call last): **
**File "function:valueChanged", line 7, in valueChanged **
KeyError: hhos_id

I can make the error go away by renaming the column[0]'s field from "id" to "hhos_id".
The new database table I created uses "id" instead of "hhos_id" so I know why the id is an issue. The query passes the id twice, as id and hhos_id to keep things happy.

The preferred solution would be to find where this mysterious line 7 is that is looking at the

I made a copy of the view, removed everything except the table, and the error still persists.

Any ideas out there? : )

Thank you a bunch!!

In the designer, right click on the table and select "Configure Events."

Look for an event that is has color:

One of these events probably has a script that contains "hhos_id" in line 7.

This looks like there is a property change script configured on your table data prop. Check your table props to see if there is a little script icon on the right hand side next to 'data'. Right-click to edit or remove your change script.

Hi Justin, All of the Configure Events are empty. That was my thought, as well.

Hi Amy,

I attached a couple of images to show what I see. There is unfortunately no script tied to the data prop. There is the query and that is the binding. No transform associated with the table query either. After disabling the binding the error still occurs.The change script is empty. I am not certain why there appears to be an error in red there. I haven't figured out how to solve that yet.

data prop Screenshot

I just re-read your original post and saw the error is on - is there a change script there?

What errors show up when you hover over the red error icon?

1 Like

Sometimes I am not the brightest. I will admit I have tried more than once to hover/click on the red error icon and nothing ever appeared. Today, I was a little more patient and there poof the errors show up. They were all pertaining to me leaving null for the header fontsize.

There is no change script tied to the table. Please see the screenshot shared above.

Did you try searching for "hhos_id" with the search tool ?


Your screen shot does not show

1 Like

That worked! There is an onChange script (line 7) that the search found. I still didn't know how to locate the script but...

Mr. Jordan Clark, your advice worked, as well. The change script is tied to data under the selection property. It is light grey in color so I never noticed it or gave it much attention.

THANK YOU everyone for offering your help here. I appreciate the help so much!!


The part on the left should tell you where it's located (the truncated part in your screenshot).

Yes, it does.
'views/Ticketing/TicketTableBackup/root/Table (onChange script on ''

I was not thinking smart enough to right click on to access Edit Change Script.