After Gateway restart Alert message goes back to default

I have an alert that goes off every 4 hours with this expression:


I have the notification settings to use a custom alert message with a subject of

CO2 Tank Level is {CO2/TankLevel}

and an alert message of

CO2 Tank Level is {CO2/TankLevel}

whenever the gateway restarts the message sent in the email is

I have found if I go into the alert settings and change the alert send to yes click ok and then change it back to no the next time the alert is sent off it will send with the custom message. How do I stop the default message from coming back?

It sounds like the initial state message that gets sent when the tag is initialized doesn’t have the right message on it. Most people don’t want to send these messages anyhow (because everyone gets emails when the system is restarted), so there’s an option to turn them off under the notification profile. Just uncheck the “Send Initial” option.

We’ll look into the message problem, though, in case you do want to send these messages.

Let me know if the “Send Initial” is already unselected on your system, though.


the send initial is already turned off. It has been turned off since this post viewtopic.php?f=70&t=6966

Ah, ok. I suspect that it may not be finding the referenced path on startup, and is reverting to the default because of that. I’ll see if that’s possible or not.


I just wanted to let you know that I haven’t forgot about this, but haven’t been able to look into it yet. I did confirm that it will simply fall back to the default message if an error occurs parsing the custom message, but it should log an error.

Anyhow, I intend to tackle this next week, and hopefully I can find something in time for the 7.3.3 update.


Okay, thanks for the update.