Alarm Filter for UDT for alarm status

I presently have a UDT created for my Dynamic drives in our company and thus Parameters passed to a device page’s popup., I created various Alarms on the drive UDT want to view the alarm per device when it is clicked on for the alarm status. At the moment, All the alarm are listed and not the alarm related to the device on the page popup

Does anyone have the best approach in setting it up properly? Well appreciated

Within your UDT, create a string memory tag which references {PathToParentFolder}.

On the popup’s alarm status table, bind the “Source Filter” with an expression such as:
" + {Root Container.FOLDERNAME::PathtoParent} + "/

This will only display alarms for that machine’s popup.

Use an asterisk in the fist set of quotations and after the / within the last set of quotations.

1 Like

Thanks for your response, I have completed the first line of statement and having issues completing the following:

On the popup’s alarm status table, bind the “Source Filter” with an expression such as:
" + {Root Container.FOLDERNAME::PathtoParent} + "/

This will only display alarms for that machine’s popup.

Please can you breakdown the step required. Thanks

When I wrote my original response, I wasn’t aware that asterisks wouldn’t show up, so I’ll use [wildcard] in my examples instead.

In my example, I named the string memory tag “PathtoParent”

In the alarm status table that’s located on your parameterized popup, bind its “Source Filter” with an expression:

" [wildcard] " + Insert the tagpath to your referenced UDT PathtoParent tag here + " / [wildcard] "

Substitute an asterisk anywhere I’ve used [wildcard]

Not working, here is the command I ran:
" + {Root Container.Bind::PathtoParent} + "/

However, I created a parameter in the popup page which has the alarm status as ‘Bind for the name’ and the type as drives (UDT). I went to the source filter and enter the above command. Right now, I am having all the alarms with no filtering. Is there something, I am doing wrong, Thanks for the help.

Not working, here is the command I ran:
" + {Root Container.Bind::PathtoParent} + "/

However, I created a parameter in the popup page which has the alarm status as ‘Bind for the name’ and the type as drives (UDT). I went to the source filter and enter the above command. Right now, I am having all the alarms with no filtering. Is there something, I am doing wrong, Thanks for the help

Inside of the UDT, add a separate member titled “PathtoParent”. Make that member a memory string tag. In my example, I’m using an actual tag created within the UDT.

Verify this tag is reading properly.

If you’re passing your UDT into the popup as a property, just reference the new pathtoparent tag as follows: (substitute your actual path)

Hi there thanks for the help,

however, it does not work either…

passed the parameter of the number on binding source filter as below:
" + {Root Container.drives} + "/
and then on the display filter used:,

drives to filter. Thanks.

Firstly, to show an asterisk, or any formatting for that matter, include your code within preformatted text characters `` e.g
'*' + {Root Container.DeviceTagPath} + '/*'

Secondly, how are you opening your device page/popup? Do you pass the path to the device and its name, or do you use a UDTType parameter? If it’s the latter, you’re on your own as I have stayed clear of these for years. If it’s the former, then you should just be able to use the above expression.
There was a bug in v7.9.5, where in the alarm source field you had to include a prefix:
'*:/tag:*' + {Root Container.DeviceTagPath} + '/*'
From memory, will check when at laptop.

Also, I’m assuming that you’re creating a binding expression for the source filter, and not just copying that as text into the source filter text?

Thanks All for its worked

Hi, I am also trying to have alarms of a single machine in the popup. I have created custom String property in the pop up and have ‘’ + {Root Container.TagPath} + '/’ as the expression in the source filter for alarm status table. But still table is displaying all the machine alarms. Can you please tell me where I am going wrong?

Can you copy and paste the resulting value that’s now in your source filter field?
Also, you need to include asterisks as wildcards otherwise it will match (or it should match) your filter exactly.

E.g. your resulting field value should be something like:
*Machine1/Drive Motor/Current/*

Also and importantly, what version are you running? as there was a bug in version 7.9.5 where you had to include a prefix as well (further up in this topic)

This is the expression in source filter:image
and source filter value is image . I am using version 8.0.15

Well in this case, it will be showing all alarms as you’re not filtering them (apart from saying that they need to have a single forward slash in them).
Are you setting your TagPath property?

Yes, I am trying to set Tag path property(this is custom property in pop up window). I understood why it is empty, because I haven’t set any property and also not passing any path to it. but I am not sure how to set the path.

Well I always pass _DeviceName and _DeviceParentPath (prefixed with an underscore so I know which properties I should be supplying) to a popup as custom parameters, and then I combine these together into another custom property called DeviceTagPath:
{Root Container._DeviceParentPath} + '/' + {Root Container._DeviceName}

Thanks. I will try this.