Alarm Notification Email Settings

I am attempting to set up an alarm notification the send an email when the alarm goes high. I am trying to use ‘My’ Gmail account to do this. I have smpt.gmail.com as the hostname. I have tried both ports 587 and 465. I am using my personal username. There is no place to put my password. I attempted the change password checkbox and entered the existing password, but no luck.
I tried the same settings in the networking/email settings and sent myself a test email (from my personal account to my work account). The returned error is 'Couldn’t connect to host, port: smtp.gmail.com, 587; timeout 10000;
Using Ignition 8.0.6

Hi, have you find the solution?
I also facing this issue, I tested the same configure on Ignition 7.9.8 and result working perfectly.

gmail needs an app password, and that’s going away soon.

Tried, but no luck.
The error message is as below : -

Same gmail account, same configure working fine in Ignition 7.9.8.
What do I missed in Ignition 8.0?

Hi Kathy - I had reviewed the same post about google turning off access for LSAs a while back. It seemed a little unclear to me if it actually would prevent Ignition from being able to send emails through gmail. This snippet from that post is what stuck out to me:

Scanners and other devices - No change is required for scanners or other devices using simple mail transfer protocol (SMTP) or LSAs to send emails. If you replace your device, look for one that sends email using OAuth.

Seems like Ignition is using SMTP to only send emails so I would think it would still work even after they turn off access for LSAs. But maybe I’m being overly optimistic since I really don’t want to have to figure out a different email solution for all of our installations…

We use gmail with our Ignition 8 installation and haven’t run into any issues. Screenshot of the settings below. We aren’t using an app password, just the regular username and password you would usually use to sign into gmail. Any chance this 8.0 installation is running on a different machine that is getting blocked by a firewall or computer settings?

1 Like

Hi WillMT10, Thank you so much for the information and highlight “blocked by a firewall or computer setting”

Both Ignition 7.9.8 & 8.0 tested on VMs with Redhat and both firewall and SELinux is disable.
As your highlight, I check again the setting and communication and found that the VMs for Ignition 8.0 cannot ping smtp .gmail.com.
I disable and enable back the network and now is working fine.

2 Likes