Alarm Notification Setup - Testing Email not Sending

I am not receiving any of the test emails of the Alarm Notification Pipeline that I’ve setup. I am running Ignition 7.9.4 on Windows Server 2008 R2.

I have setup the following:

  • AD/Database Hybrid source which I have been using successfully for SSO
  • Roster is taking users from the source above (which have emails assigned)
  • Alarm Notification Pipeline created globally within a project, named Process_Alarm
  • image
  • Alarm Notification Profile created, named Process_Alarm_Email as email notification
  • I am using the Gmail SMTP server, which I have been using successfully sending emails for scheduled reports in addition to clients reporting an error during runtime to me as the admin

I have tried typing in the email setting directly without the SMTP option using different username and port combinations (full email, just before, port 25, 465, 587 to no avail). Any help would be appreciated. I turned on trace, which shows no errors.

Well I figured it out after much manipulating, ended up manually entering the email settings using full email address on port 465 and it worked.

what do you mean, could you share an example?
in which field/form did you enter such value?

For the record, i was able to make it work. i used this in my SMTP profile

hostname =
port = 465
Use SSL/TLS port = True (checked)
username =

Now, here is the thing. I have 2 machines with ignition: one is a physical PC with the active license and the other one is a virtual machine with trial license. I use the later to make tests. The thing is i use the same SMTP profile in both machines but it only worked in the PC.

probably, there is some issues with this functionality while using it in a virtual machine or with the trial license (or both). If anyone else has had this experience (or any other where behavior is different in physical machine vs a virtual one) please share it so in the future developers are aware of this condition.

PC info:
operating system=opensuse 15.2
VM info:
VM operating system=opensuse 15.2
host OS=opensuse 15.2
virtual machine=KVM

the error i get in the logs is “unsupported or unrecognized SSL message”.