Alarm notifications, trouble getting working - "No alarms in this pipeline"

I am trying to get email alarm notifications to work, in a development environment, this is in a trial system yet. It seems I have everything set up correctly, going through it carefully. I am using Gmail for the smtp server currently , although we do have an smtp server in house that I can use as well. The settings are smtp.gmail.com, port 587, using known good Google credentials for username and password.

In the Alarm Notification Profiles test page on the gateway, it doesn’t work, and I get a “No alarms in this pipeline”.
I can trigger the alarm in a PLC I have hooked up and watch it come up on the alarm display, and also on this notification page I notice it will show up when I trigger it under the “Source” section, count up in the “Time in Block”, and then come back with the same “No alarms in this pipeline”. So, it does appear that the system is recognizing this alarm and it is getting into the pipeline. I’m just not getting the notification via an email message. Thanks much for any troubleshooting help.

Anything in the gateway log? Rejections from google would show up there.

I hadn’t been checking there, unfamiliar with it, but I dug around and found it, thanks.

When I trigger the alarm, I get the entry below, if that is coming through. So, it is a failure in sending. So far I’m not seeing a way of getting further detail if there is any.

I’m not seeing any other entries related. Is there anything more to check for, or just something with the smtp settings not working? Thanks again.

image001.png

It says “this profile is running in test mode”. Seems pretty clear. Edit the notification profile block to not be in test mode.

OK… I wasn’t interpreting ‘that’ was the/a problem, and I guess should have.

However, I’m not seeing in the setup of email notification profiles where there is any setting for ‘test’ mode. I can see ‘enabled’, not that.

If this is because we are using ‘Trial’ mode yet and it won’t work in Trial, then that is one thing, and if I know that, I’ll stop trying for now until we get this activated. I was just looking for the e-mail to actually come through to my inbox as an end result, to see it and demo that to people here. If that is indication that it ‘would have’, then I will trust that.

Thanks.

image001.png

Look at the notification block in your pipeline. That’s where test mode is set.

OK… Yup…, I didn’t tune into that property setting as being a problem, but yeah, it got me past this error, and then onto the next. But now with the error I get, I can expand the detail in the gateway log and find out more, that the smtp server is not taking the username and password, so I am off and running. Google not letting me in now, so maybe I will try our internal smtp server. Thanks much for the help.

image