Alarm Status not displaying Remote Tag Provider Alarms

We have a scale out Ignition architecture with Alarm Notification module on the BackEnd and need to display alarms on the FrontEnd which doesn’t have Alarm Notification module. The FrontEnd is using the BackEnd Remote Tag Provider, and the BackEnd Remote Alarm Journal but the active alarms are not being displayed in the Alarm Status Component.

I feel like I am missing a simple setting somewhere. Anyone with thoughts on this?

A few things come to mind (assuming you’re on 8.1):

Is your front end remote tag provider configured for alarms? Note that I’ve had issues in scale-out architectures where an alarm mode of Queried didn’t actually show every alarm on my front end. Changing that to subscribed fixed it.

On the back end under security>service security, have you allowed alarm access to the remote gateway (aka the front end)?

All settings are as you indicated but not sure where to the the “subscribed” feature.

:frowning: no luck…

interesting thing is that i can see them from script console…

props =
state = [“ActiveUnacked”, “ActiveAcked”]

alarms = system.alarm.queryStatus(any_properties = props, state = state)

print len(alarms) => 3

The subscribed/queried setting is under Tags>Realtime>[your remote tag provider on Front End].

Dumb question, but does your alarm status table have any filters on it that could be hiding alarms? Note that the source filter doesn’t expect a basic tag path ([default]path/to/tag), but actually a qualified tag path (prov:defaut:/tag:path/to/tag*)

Not a dumb question because it feels like a dumb thing…

I got the Front End tags set to subscribed… but the interesting thing is I have another gateway ver 8.1.16 with the same Remote Tag provider with Alarm Mode set to “Queried” and it displays the Status Table. The Front End is ver. 8.1.12

The status table doesn’t have any filters.

Hmm. My final thoughts before I’m totally out of ideas - are you able to restart front- and back-end gateways? Or if you can’t restart right now, perhaps you can restart a specific tag that has an active alarm? When in doubt…

The tag restart didn’t work… took a bit, had to coordinate the restart of the FrontEnd Gateway. But when I did it solved it!! Thanks so much for your time and efforts.

1 Like