Alarm Status Table Default Filter Not Working

Hi, I have problem about default filter from Alarm Status Table.

This picture is from Designer and I want it for default filter configuration. (Filter State without “Cleared, Acknowledged” and sort for “Active Time

And this picture is from Perspective Session that actual happened…

Why the default configuration from designer its not applied to perspective session? From perspective, filter for states that applied is “Show All”. That is annoying because the “Cleared, Acknowledged” alarm is always appear. Also, why sorting mode for “Priority” and “State” suddenly applied?

Hope anyone can help this issue, thank you!


What version are you using? Your Session screenshot looks like a nightly build (or RC build) for 8.1.0, where we’re aware of an issue in how filters are applied to a table (which is to say, they aren’t - it will be fixed for 8.1.0 Stable).

As for setting “Active Time” as the sort order, you need to configure the relevant properties. In the following screenshot, note that I have specified the column should sort in descending order. I ALSO was required to include the activeTime column as a value in the props.activeSortOrder list. To get your EXACT appearance, you must also remove some sorting we appear to always have in place by default; locate the sort property for the priority and state columns and set the value to none (it looks like the reason for this is that we sort by activeSortOrder values first, and then we sort by columns which have sort configured but not ordered and we do so by their column order in the Table).

Screen Shot 2020-09-30 at 6.04.14AM

With those modifications in place and a working build, your table should look like this:

Yes, I am using Ignition version 8.1.0 RC1. Thank you for the “sorting problems” guide. I can’t wait for Ignition version 8.1.0 Stable to resolve the “filters problem”. :+1: