Allow user admin - overlay error

Hi

I have selected the “Allow User Admin” option from “gateway>config>security>general>allow user admin”. Despite that I get an overlay error on my user admin component in my client! I have the nexessary permissions to operate this component from admin user. What could be the problem!

image

Also when I add/delete roles/users in gateway, the designer doesn’t see the changes until I close and open the designer again! Is that correct?

Does the project’s properties also have user admin enabled? And yes, I think it is normal to have to re-open the designer/client.

Yes! That was the issue!

Thanks for the confirmation about the designer behavior.

Another thing I noticed is that the user management and the on-call roster management components are not WYSIWYG in the designer and the client display! Is that right or am I doing something wrong!

The designer screen ;

in the client screen it looks like this

see the overlapping windows!
What could be wrong! or is it normal?

However having this option at two places (Gateway as well as in project properties in designer) looks redundant and confusing to me !

I believe gateway option prevents any project from editing users. Per project setting allows you let some projects edit users and not others.

1 Like

May be! But the gateway setting should reflect in project properties in designer at the beginning! Nothing serious but its not obvious that this option exists in designer as well, I had to scratch my head a lot as to why it was showing the overlay error! I got frustrated and decided to post it in the forum!

Also any idea why the user management component and the on-call roster component do not maintain the same spacing in designer and the client! I know that we can play around with the layout and anchor properties but its frustrating to do the trial and error. Or am I missing something!

It would probably be handy if project properties noted gateway setting was required too. I don’t know if there’s a note on the gateway setting referring to project properties, but that would probably be helpful too.

I’m not sure what’s causing your layout issues. Does it work when both are set to relative layout?

Yes perhaps a mention in the gateway config page that this setting can be overridden in the designer>project properties would be helpful. But even if that can be done, the designer launch should inherit this setting from gateway. However even if it inherits it, the change in this setting in gateway after the designer is launched will not reflect in the designer unless its restarted! (I assume so based on designer’s behavior I have seen for other settings). So this option in gateway is in my opinion redundant, and can be safely removed, allowing it to configured in designer alone. (That’s purely my opinion, IA knows it better!)

Regarding overlapping of the user management and on-call roster windows, perhaps I should try with bigger size of my main window! I haven’t tried relative layout, but will try some more options.

Thanks for your reply!

regards