An acceptable version of java was not found

Some of our clients have recently installed java update 14 and everything quit working. I reviewed this post…

http://www.inductiveautomation.com/forum/viewtopic.php?f=26&t=2685
then I deleted the reporting plugin and reinstalled.

The gateway launch page still shows that the client has an unacceptable version. What should I look for or try next?

FPMI 3.3.2

Thanks,

This is actually unrelated to that other issue. I’m guessing you are using IE8 or aren’t on Windows or are using some other browser. Our java detection javascript leaves something to be desired. Note that this message says that if you hit “cancel” it’ll try to launch anyways.

Feel free to turn off javascript detection in the config/system/settings area.

Yes, I now see what you mean.

I have the certificate problem with two computers. (Both have update 14)
One computer has IE and an acceptable version of java and the other uses a different browser and shows an unacceptable version of java.

The orignal problem was “Unable to launch” and the details showed a certificate problem. I made the mistake of linking the java version issues together.

I still cannot launch a project though. I went so far as removing the reporting plugin and restarting the gateway.

Thanks,

Have you cleared the java cache (Control Panel > Java > Settings… > Delete Files…) and the browser’s cache?

I deleted the files under java > settings but not the browser. After I uninstalled update 14 it worked.

I will try deleting files from both java and the browser on the second computer.

On the sceond computer

Browser: Google Chrome
OS: XP Pro

Control Panel > Java > Settings… > Delete Files. Deleted all files
Browser: deleted all temp, cookies and history.

Still unable to launch so I gave up and uninstalled update 14.

Thanks,

Did uninstalling Java 6u14 help? And I’m getting a bit lost - you were unable to launch because of the certificate problem or a different problem?

Yes,

and uninstalling Java 6u14 solved the problem.

When I went to the computer that was using google chrome and saw the “not an acceptable version” I thought that was the problem. But, You were right.

He was using Google Chrome.

The other computer that had the certificate problem had internet explorer for a browser and it showed that the java version was OK.

I have since discovered two more clients that have a certificate problem and J6u14. I will uninstall these next week.

Have a good weekend!!

Ok, thanks for clarifying, I’m tracking you now.

:scratch: I really don’t think that it should be necessary to unistall 6u14. I know lots of people who are using 6u14 sucessfully. Are you using any other plugins? Like maybe the ActiveX plugin?

Yes, I do have the ActiveX plugin version 1.0.2

I have not implemented it and I doubt if I will. Should I uninstall it or upgrade?

Yeah, all plugins need to be upgraded for 6u14. If you’re not using it go ahead and remove it. Otherwise re-download it from our plugins page - the new version shouldn’t cause the certificate problem.

I just wanted to follow up on your last post.

I removed the activeX plugin and reinstalled Java 6u14. Everything is working OK.

Thanks,