AnyBus ABC3090 problem reading MODBUS TCP

Hi everyone, we are trying to read data from an AnyBus ABC3090 with MODBUS TCP firmware.
From the quick client I see the data in form of number, but in the designer I cannot read anything.
I've tried configuring the tag manually or using the device addresses, but no value appears. The tag remain empty.
The Area Map of the Anybus devices are configured as follows:

So for example, if I want to read the string "Product Code Name" I think I have to put ns=1;s=[ABC3090]IRS2:16, if I'm not wrong, and the tag Data Type must be string.
Is this correct? Someone can help me?

Ostensibly, that looks correct, assuming that the unit/slave ID you're supposed to use is 0 and that you should be reading Input Registers and not Holding Registers.

Are there errors in the logs? Do you have other Modbus software (like modscan) that can read these values? Can you get a Wireshark capture?

With CAS Modbus Scanner I can read these:


Well, that looks like it confirms they are input registers, but not the unit/slave ID.

In the configurazione of the CAS ModBus Scanner I've put 1 as Device ID but it works in the same way also if I put 0. So I don't know what I'm doing wrong.

Use Wireshark to compare traffic.

I've solved the problem, it seems that were too much errors on the tags that was created before of this one binded to that device. Cleaning all the wrong tags do the tricks...
I was thinking I was doing something wrong in the configuration, instead was only that :frowning: