Application Error - Unable to Launch Application

Working with ignition installed in a VM for development. Everything was working fine for a while now. Went to launch today and received the error Unable to Launch the application.

Details:
com.sun.deploy.net.FailedDownloadException: Unable to load resource: http://localhost:8088/main/system/launch/designer/designer.jnlp
at com.sun.deploy.net.DownloadEngine.actionDownload(Unknown Source)
at com.sun.deploy.net.DownloadEngine.downloadResource(Unknown Source)
at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source)
at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source)
at com.sun.javaws.Launcher.updateFinalLaunchDesc(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.launch(Unknown Source)
at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main.access$000(Unknown Source)
at com.sun.javaws.Main$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

The designer won’t launch, the gateway webpage won’t launch and the gateway service will not start from the control utility.

Java 1.8.0_161-b12

You’ll have to look in the gateway at the wrapper log file to see what’s happening.

Thanks Phil,

This is what is noted in the log when trying to start:

The Java Runtime Environment home directory could not be located in the system registry.

Huh. Never seen that one. But I don’t use Windows servers for Ignition. I’ll let someone more familiar answer. Might just need to reinstall java.

I have tried a reinstall (using the same version that was present)… no luck :unamused:

Thanks anyways, hopefully I can get to the bottom of it and more importantly understand why it happened…

You might take a look at these resources (full disclaimer, I put these together :slight_smile: ) for some quick (and pain-free) ways to spool up dev environments quickly (and independently from your host system):

Vagrant Option

Docker Option

https://store.docker.com/community/images/kcollins/ignition

Hope this helps!

1 Like

Tried reinstalling again only this time went to oracle’s site and chose a specific 64 bit installer and everything appears to be working now. It looks like accepting the latest Java update through the update utility took the default 32 bit version and removed the older 64 bit version. Will have to be more vigilant with update procedures on windows machines.

Thanks for the suggestions!

1 Like