Application Error - Unable to Launch the Application

I’ve been having issues trying to launch any project or the development environment, any FPMI application. I have been able to run in the past on this machine, which happens to be my laptop.

It looks like the gateway server is rejecting the client, or a network issue? Other machines taking the same network path seem fine, so I was wondering if I was missing something on the client side. I’ve cleared the java cache, browser cache and even uninstalled and reinstalled java. I’m able to connect and browse the gateway from this machine without issue.

Any ideas?

Error Information:

As soon as initial download completes, I get:

Under more information, the error is:

The wrapped exception is:

[quote] Server returned HTTP response code: 403 for URL:
at sun.reflect.GeneratedConstructorAccessor1.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at$ Source)
at Method)
at Source)
at Source)
at Source)
at Source)
at Source)
at Source)
at Source)
at Source)
at Source)
at Source)
at Source)
at Source)
at com.sun.javaws.Launcher.updateFinalLaunchDesc(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.launch(Unknown Source)
at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main$ Source)
at Source)
Caused by: Server returned HTTP response code: 403 for URL:
at Source)
at Source)
… 18 more[/quote]

Huh, you’re getting an HTTP 403 trying to load the JNLP file (which is the file that helps Java launch the client or designer). This means “Forbidden”

Log into your gateway configuration section - do you have any IP restrictions set in “Gateway: Allowed Addresses”? (under System > Settings)

If not - describe the network between this machine and the server - any firewalls or routers?

I have 192.168.. in the “Gateway Allowed Addresses” and the “Gateway restrict connections” check box is not checked. I think this has been that way - I haven’t set it? I did restore/import your skeleton project, but I don’t believe this would change these settings.

The firewalls are off on my laptop (client) and the gateway machine. The gateway server machine is actually a virtual server with a dedicated NIC.

As far as the network, both client and gateway machines are in my office and I’ve been through a couple variations in an attempt to eliminate what I thought might be some possible. In my latest configuration, the gateway machine and the client machine are plugged into an unmanaged switch which is up-linked to our control VLAN, the 10.12.11.x network.

Initially, my client machine had been plugged into another VLAN (10.12.13.x) that is routed to the other VLAN. Physically, these are both connected to a Cisco catalyst blade system. This setup used to work, and based on some IT queries, “nothing has changed.” In fact, I had been able to use our VPN which comes in on another VLAN (10.12.12.x) without any issues.

I have tested another machine in another location of our facility that is on the same VLAN as the gateway (10.12.11.x) . This is going from a Cisco satellite switch to the Cisco catalyst to office, and all is well. I’ve also tested running on a terminal server that exists at a remote site, running across the WAN. All is well.

By forbidden, you mean the server / gateway is dong the forbidding? Wouldn’t access to the gateway configuration and launch web pages be forbidden also?

Based on the stuff listed above, it sure seems like it’s the client end, almost like the jnlp is being denied from running. I just don’t know what it can be?

Any known issues with antivirus, specifically Sophos? I did notice in my system log I had a new install pushed to my client machine several days ago. It’s had been running Sophos for some time however, and some of the other working clients are running. I’ve disabled the antivirus as a test and get the same results. I might request it be removed and try that if I can’t come up with anything else.

Nah, I don’t think its the antivirus.

JNLP’s reference themselves. I think that you are downloading JNLP just fine, but then when java web start loads it up, it actually downloads it _again_from the url specified inside the JNLP. I think that URL is wrong.

Do you have clustering turned on? Auto-detect http address on or off?

Do this: On that client machine, do Start > Run > javaws -viewer

Find the application in that window, right click on it and choose “Show JNLP File”

In there, in the very beginning, is an href= that references the JNLP. What does that say?

Clustering is turned off. Auto-detect http address is on. The correct address is filled and greyed out in the box below.

The project isn’t listed in the Java Cache Viewer. I guess it never gets there. As I mentioned, I cleared all the the cached stuff. I was able to save the downloaded .jnlp file (Chrome doesn’t auto open).

The href line is:

<jnlp spec="1.0+" codebase="" href="launch/BTBoilerRoom.jnlp">
On a working client, the .jnlp file looks the same. However, on the working client javaws -viewer, the href has the full path, as do all subsequent hrefs.

<jnlp spec="1.0+" codebase="" href="">

I tried adding the full path to all the references in the .jnlp file - no change. The other thing I did was try browsing to all the href resources in a browser. They were all accessible.

Huh, well, that all looks fine. Now I’m not so sure. Can that client get to (the gateway status page)

Yes, and I’m able to login and perform configuration tasks from the client.

Go into the Java control panel (under Windows control panel), and open the “Network Settings” section.

What does it look like?

I/we got it.

I have IE, Firefox and Chrome installed. Firefox is my default. I was going to switch my default back to IE for lack of something else to do. Before doing so, I checked my Firefox network connections. For some reason, my Network>Connection settings was set to ‘Auto-detect proxy settings for this network.’ I don’t remember changing this - we don’t have a proxy. I set to, ‘no proxy.’ and all was well.

My Java Network settings were ‘Use Browser.’ I’m sure you were headed to the browsers based on this info…

Thanks for your help!

Whew! Glad you got it figured out. That was my last idea.