Arrays in Tags in Omron NX PLCs


I am working with an Omron NX (using the Omron NJ driver) and I am trying to setup a String Array and for some reason I get a configuration error. I am not sure what I am doing wrong
(see attached print screens). Neither on the PLC nor on the Ignition side I see a problem. Does anyone have any experience with Arrays in Omron and has
any idea to solve this? Is there any way to get more details on the error message? According to the Ignition documentation it is straight forward. I tried one-dimensional and two-dimensional arrays but neither work. I also tried DINT Arrays but those ones did not work either. If I read non-array tags (Strings, DINT, etc.) it is working just fine.

Any help/ideas appreciated…

Thanks, Carsten

A String array configured in the driver mapping should present itself as a folder with a String tag per element when you browse OPC. It won’t be addressable as a single StringArray type tag in Ignition.

What do you see in the OPC browser?

OPC Browser
This is how it looks like but none of the elements are accessible. I tried to read them as Array or as single String value…none worked.

Is there any other suggestion to transfer array values that are captured at a machine to Ignition if Arrays do not work. We have a machine that runs tests and creates several lines of results. These values should be transferred to Ignition.

What does your mapping look like in the gateway config for this tag?

What happens when you drag those tags in or do a read from the Quick Client?

Seems to be working on our side.

We did add the same setup you posted to our NJ device just to confirm everything works as intended. This is what the row looks like when added in the Gateway:

Thanks for your support…I got it to work for DINT array.