Auto Launch Ignition edge 8.0

Hi,
I am trying to get an edge application to auto launch on boot up but have been unsuccessful. I have tried putting the short cut to the client and the ignition start batch file in the start up menu. I have no idea what else to do so any help much appreciated. I did have a look around the docs but couldn’t find anything.
Thanks
Marisa

Same here. I was doing this in 7.9 by using the Native client launcher which keeps trying to connect until the gateway is running. But the edge launcher just gives up trying.

Were you ever able to work this out? I just install Edge on a touch screen computer and was hoping I could get it to auto start the client.

Hey, no I haven’t.
Ignition sent me this, I haven’t had a chance to have a proper look at it yet as busy with other job but on the face of it, it doesn’t look that easy to do.

If you are wanting the projects to auto launch on computer startup then you can create batch scripts or shortcut using cmd line arguments like the examples below:

Using the Command Line to Launch
The second way is run the client launcher from a command line or a desktop shortcut and add these lines to the end of the command:

“C:\ClientLauncher\clientlauncher.exe” application=myproject -Djavaws.launchparams=“LaunchTag;LaunchTag2” -Djavaws.launchparam.LaunchTag=“AAA”-Djavaws.launchparam.LaunchTag2=“ZZZ”
Starting the client launcher from a command line in this case would look like the example below (Linux example shown)

./clientlauncher.sh application=myproject -Djavaws.launchparams=“LaunchTag;LaunchTag2” -Djavaws.launchparam.LaunchTag=“AAA” -Djavaws.launchparam.LaunchTag2=“ZZZ”

Thanks that did the trick. In Linux the script for launching projects is named “visionclientlauncher.sh” by default. Since I didn’t need to set any client tags all I did was create a new startup application entry and give it the path:

path/to/visionclientlauncher/folder/app/visionclientlauncher.sh application=ProjectName window.mode=fullscreen

A note about this though. It did not like spaces in the project name. I tried use %20 to indicate a space and that would work from the command prompt but not from Ubuntu’s Startup Applications Preferences. I also tried quotes and using \ to escape the space, however none of those options worked for Ubuntu’s Startup Applications Preferences. I could have left the space in my project name and used something like a cron job or rc.local to call a bash script, but I just got rid of the space and the above code worked fine.

Bash might need you to double escape the % in the HTML escaping, so it might need to be Project%%20Name, but, yeah, generally we encourage project names to be simple literals - more “friendly” names are what the project title field is for.