Bad_Usupported and Bad_ReadOnly in Tags

ignition80
#1

I am having problems with tags in the migration from version 7.9.10 to 8.0.1. When I open a popup it is returned Bad_ReadOnly for Expression and Bad_Unsupported tags for OPC tags.
Another error, when opening the screen the templates do not load correctly.
I can not fix these errors and the system is stopped.

0 Likes

#2

You’re best option is to call support. Or re-install 7.9.10 and restore your backup (the backup from 7.9.10).

Did this not show up in your testing before upgrading?

0 Likes

#3

I did not express myself very well. The test system is stopped.

0 Likes

#4

I have the same problem. All my UDT are in failure and i just migrate from 7.9.10 to 8.0.2. How can i solve? Looks like is a problem connection UDT to ignition Tags because y write in the designer and it is working.(Designer to PLC)
Captura

0 Likes

#5

I´m performing a test right now, on a new server running 8.0.2. ( upgrade from 7.9.9) and it seems like I have the same problem with my UDT´s. The tags in the error messages are all UDT expression tags that gets their values from other tags higher up in the hierarchy, ouitside the UDT. The strange thing is that the actual values are correct in all tags, but I still get Error messages when opening popup. It´s both Bad_Unsupported and Bad_ReadOnly.
(An other thing I wonder now, is it ok to upgrade from 7.9.9 directly to 8.0.2? or do I need to make all upgrades in between as well? )
20190617_144140

0 Likes

#6

I could not solve the problem, I believe that with some updates this will be solved. For now I only contacted Inductive about these faults. If someone solves it, post it to us

0 Likes

#7

I get these errors in the logs, regarding that my SQl connection is faulted. The test server is not connected to my SQL, because my running server is now connected to the SQL. Is this the reason? Did you have the SQL connection enabled when you got your errors?

0 Likes

#8

Did anyone found a solution to this?

I have the same problem with a UDT, when I open a pop-up window with a UDT, it generates an ilimited amount of windows that return the same error “Bad_ReadOnly”

Faceplate%20Error

0 Likes

#9

I believe this problem is fixed in 8.0.3.

1 Like

#10

Hey, thanks for replying!
If it wasn’t for your reply, I would’ve missed the update.

And yes, the problem seems to be solved, it doesn’t show up anymore (neither on Designer nor on the client version).

1 Like

#11

Great, I am glad to hear that!:smile:

0 Likes

#12

I’m having this problem with one tag in 8.0.3, any ideas what’s up?

0 Likes

#13

Nevermind, managed to fix it, had some conflict on the MQTT source gateway and fixing that seems to have fixed the problem. I remember having fixed it earlier, but maybe the changes weren’t saved or something.

0 Likes