Badger FC-5000 Addressing

https://www.badgermeter.com/resources/d02a7302-22aa-4180-9983-0f2466c6aec4/fc-5000%20flow%20computer%20user%20manual%20ctl-um-01723-en.pdf/

Page 50 shows modbus Addresses.

Has anyone out there tried to use the Badger FC-5000 with Ignition?

I’m trying to get numbers out of the flow total 1 and flow total 2. However, unlike out Krohne flow meters which use IRD to gather the data I can’t seem to get anything to work. I have tried HR, IR, HRF, HRUS, etc. Nothing I try works. The devce is connected in the gateway, all the settings seem to be correct but I just can’t pull any data out of the FC-5000 flow meter and put it into ignition. Any thoughts?

I’ve been using flow total 1 as my go to address to try and get this working. Ex. HR2, IR2, HRF2. etc.

Have you tried toggling the one/zero-based addressing? Seems like this device is starting at zero.

The default slave/unit id used by Ignition’s driver is 0 - maybe this device is expecting a different value?

What driver are you using? This documentation only talks about Modbus RTU/ASCII.

I have indeed tried the one/zero-based addressing. Both options have no effect.

I think the device is set by default to slave address 001. I do not know if 0 is an option.

Also yes, the FC-5000 only does modbus in RTU or in ASCII. Is that an issue?

For address 2 to be the value you think it is it looks like you’ll want the driver to be in zero-based mode.

You can address a different slave address in Ignition. Just modify your OPC Item Paths so they look like [device]1.HRF2.

Maybe. How are you connecting to this thing? Do you have the serial module installed and you’re using the Modbus RTU driver? Are you using Modbus TCP driver through a gateway? RTU over TCP through a dumb serial-ethernet converter?

~ Ok that’s what I have it set at. Same as the Krohne Flow Meters

~ I am also assigning the address this way. Just like with the Krohne flow meters that are set to slave one.

~ I originally tried both modbus driver RTU and the Modbus TCP. I’m currently using the modbus tcp driver. However, the FC-5000 was having issues before a firmware update and since then I have not tried modbus RTU.

~ We use the ADAM-4572 devices to access devices that use modbus.
https://www.advantech.com/products/db72f61c-801b-4e61-8863-5d418f01b6e9/adam-4572/mod_1e01192d-95a1-42a4-b199-79343134f4ca

Ok, seems like you’ve got everything set up correctly to me. Are there any errors in the Ignition gateway logs? Is this thing just not responding to the requests or is it returning error codes?

Can any other piece of software get data out of this thing via Modbus? Have you tried a simple Modbus scanner or another OPC server?

~ Nvm, nope it’s acting like nothing is happening. Those error logs I just had up were for something else. At least I think the logs were not for this device.

Yes it can. we even sent the device and the ADAM-4572 to badger itself and with their software they had no problems polling the data.

One thing to note however, when I try to poll from the device the modbus driver disconnects and reconnects every 5 or so seconds. Then when I turn off the tag that is trying to poll the data from the FC-5000 the modbus driver stays connected.

I’d either be looking at comms between the ADAM and the badger, settings on the badger, or trying to track down a Wireshark capture of a working Modbus connection between some other piece of software and the ADAM/badger combo to compare the difference with the Modbus traffic from Ignition.

I will have to try wireshark because we have a test station that I set up this morning with the FC-5000 now connected directly to the Ignition server.

If I gather any data of use I will post it here.

I finally got it to work. Turns out there was a ghost (remnant of a discontinued device) on the network with the same name causing duplicate network devices. I deleted the entry and used “[device name]1.HRF2” and it all works now.

Thank you for your help. If I hadn’t wireshark’d the ip address and found conflicting information it might have taken me even weeks to figure this out.

2 Likes