Big Query datasets and table names

I’m trying to run a named query against Google Big Query (BQ).
Formatting the tablename is causing a problem.
My tables in BQ are organized thusly: Project.dataset.table

If I run a query against just the tablename i.e.( INSERT INTO tablename …) I get a nice error from Google telling me to include the dataset name as well.
When I include it ( INSERT INTO datasetname.tablename …) I get a 404 error Projectname:datasetname.tablename does not exist. notice that semi colon.
When I run a query in BQ’s online console I use the full “path” (INSERT INTO pname.dname.tname …).

On a whim I tried this as the format for my named query.
I did have some success but switched back to a testDB with a different table scheme.
On switching back to the BQ DB I can’t seem to get this query to work.
I’ve re-tried the three combinations above and haven’t been successful.

Anyone out there use BQ with there projects?

EDIT:
It was a capitalization error.
I ended up on (INSERT INTO pname.dname.tname …) working successfully.

1 Like