Bind OPC Server IP to VPN IP

Has anyone been able to bind the Ignition OPC-UA server to a different IP address? More specifically to the VPN IP that the computer is receiving, not the main WiFi or Ethernet IP. I have gotten it to work with the WiFi IP thought but not the VPN IP.

I have set the OPC-UA settings bind address to the VPN IP address and can’t the the OPC server to connect, can’t even get the discovery part to find anything.

Now I changed it to and it discovered the OPC, I selected and used that and it still is failing.

For my cloud environment to connect to this OPC server it needs to be using a static IP that I allow on the cloud, which I have already made that change.

Anyone have any suggestions on this?

Assuming all the networking stuff is set up correctly I would expect the following settings to work:

Bind Address List:
Endpoint Address List: <hostname>, <localhost>, VPN_IP_ADDR

Restart Ignition after saving the settings. First make sure the loopback connection still works. It should, without any changes from its default (i.e. “opc.tcp://localhost:62541/discovery” should still lead to a connection).

Then from what I’ve gathered you have an Ignition or some other OPC UA client in the cloud trying to connect down to your local gateway. This is where you might have to ensure network/firewall stuff is taken care of. If it is then you’ll be able to reach the gateway at opc.tcp://VPN_IP_ADDR:62541/discovery or at the very least telnet to VPN_IP_ADDR:62541.

Why should I used port 62541 instead of 4096?

Maybe it’s 4096. I’m assuming defaults for 8.0. If you upgraded from 7.9 it’s still 4096. If you’re still on 7.9 you won’t get this to work and none of these settings exist.

Are you saying this won’t work at all for 7.9?

I think it’s very unlikely because 7.9 doesn’t allow I don’t think works right in 7.9, it doesn’t allow multiple bind addresses, and doesn’t have this separate endpoint address list setting.

I can say that it does work and here’s why.

In our cloud we have 2 different Ignition servers, one that has the OPC-UA module only and the other has alot more modules (comms and production server).
All the devices that the production server needs to view, are viewed using the OPC-UA server on the comms server (where all the devices are created).

That tells me that it should work. Right?

Sure, but those in the same network with real network adapters.

If this is 7.9 then you can try setting the “Endpoint Address” server setting to either or the VPN IP. Any change requires a restart. It’s going to work or it’s not. I don’t know what else to tell you.