Blocked Reporting Threads

Late yesterday I was working on a query for a report when the report locked up on me. Now I have 13 blocked threads and my CPU usage has jumped about 20%. All the blocked threads are listed as for reporting but show 0 CPU usage.

I found one thread listed as RUNNABLE that is also a reporting thread that is hovering around 20% CPU usage.

Has anyone seen this before? How can I clear the blocked threads and get my CPU usage back to normal? I’ve tried restarting the reporting module with no affect. I’m trying to avoid restarting the entire gateway but I’m starting to wonder if I will have to.

Do you have any scripting in the reports? You might have an infinite loop or some kind of cpu hog in there.

You very likely will have to. Post the thread dump, or get in contact with support, and someone can give a better idea of what’s causing the blocked threads.

I just got off the phone with support. Reporting is causing the blocked threads but there isn’t anything calling for a report to run right now. The single runnable one I showed before is linked to the other 13 blocked threads. I’m trying to get the gateway restarted now.

pturmel, I wish it had to do with scripting. Would of have made me feel better having a target to look at to fix it. I had just started building up the data sources for the report so their isn’t much to them right now. Their only SQL queries at the moment. It all started when I tried to add a UNION into one of the queries.

UNION can be very expensive if you have many rows since it tries to eliminate duplicate rows requiring a lot of comparisons. Did you perhaps mean to use UNION ALL?

Still kind of weird though because you’d figure the query would perhaps timeout unless the timeout limit has been raised/removed.