Both CITEC and FActory SQL at same place,still problems

Dear All,

I am using Vijio Citect SCADA System in my PC and also i am using Factory SQL in the same PC( That means both are locally).When i run the frontend , it showing Citec.Opc,Citec.Remote.Opc.When i click on it ,it is giving error as “E_NETWORK_ERROR, Could not connect to the server”. I run other appication which come up with factory SQL set up named as OPC Client, it is working fine.

Please let us what we need to do at CITEC side or Factory SQL Side, since i am running the both the applications in the same machine.

Thanks in advannce,
Software Engineer

From the email you sent in, the message goes on to say “Class Not Registered”. This would possibly indicate a problem with the OPC setup. First, try going to Settings->Service Settings and select “Use OPC DA 2 when possible”, and then try to browse again.

If that doesn’t work, try closing all OPC applications and re-running our installer- select “custom install” and only select “Install OPC Core Components” from the Extra Software section. This should hopefully get things in order.


Dear All,

I tried with other vendor software which is named as “dOPCExplorer”, Which is showing all the tags.
I have tried to change the settings and re-install the factory components , still the browser is not showing anything in FACTORY SQL.Please look into this issue , and please letus know what we need to do at our end .
We are awaiting your responce.Thanks in advance!!!

Thanks & Regards,
Software Engineer


One big difference between those OPC browsers and FactorySQL is that those applications run under the current logged in user, and FactorySQL runs as a service, under the System account.

Please take a look at this thread, which outlines how to run FactorySQL as an application. It is normally desirable to run FSQL as a service, and sometimes these types of problems are simple security issues, but occasionally we’ve found it necessary just to run it as an application.

Please let us know if running as an application helps. Also note that I’ve merged this post in with your previous one- it’s better to keep the related topics together. Please just reply to this thread.


Dear Colby,

We have tried the things which you mentioned to run as an application, after settings all the things we start the factory sql frontend end, still it is not showing any tag details.Please let us know what we need to do next.

Thanks & Regards,