Browser Autocomplete

Is there anyway to disable the browser autocomplete in Perspective? For forms etc… Specifically drop-down lists.

It’s not currently possible to disable autocomplete (by setting the autocomplete attribute) but I’ve bumped the internal ticket to add the feature that was filed a few months ago.

Thanks for the info.

Any hacks that I can do in the meantime to accomplish this?

It doesn’t look like it; CSS via themes can’t inject an actual HTML attribute. You could maybe try generating a random component name (which would, naturally, make your binding setup a lot harder); most autocomplete tools rely on ‘knowing’ the component name and ID, but no guarantees, and that’s a whole lot of work.

Hi any update on this? Or any indication on when it might be available?

It’s on track to be added in the next few releases if nothing else comes in at a higher priority.

thanks for the update

This issue is currently going through testing, but there are some questions raised by this thread.

@bschroeder , Are you asking about preventing users from narrowing down the available options based on some typed text? Your question really sounds like you can accomplish what you’re looking for by setting Dropdown.props.search.enabled to false. If that’s not the case, could you provide some screenshots of what you’re seeing with the Dropdown?

I’ll try and get a video tomorrow.

Basically the browser is presenting it’s own list of options based on previously entered data, and covering up the search/drop down portion. We can’t eliminate the search.enabled feature because the client needs it.

Please. Also, what browser are you using? Where did the available options come from? Are they options a user previously selected, or are they from other sites and are stored within the browser?

OK I’ve got a video but I can’t post it here because of personal stuff on it. Can I PM it to you?

The options are generated from the browser, and has no bearing on the Perspective site. It’s just similar data… ie an address or related stuff. This is occurring in both Edge and Chrome.

PM works.

The next Nightly will contain a change to the Text Field, Text Area, and Password Field components to allow access to the autocomplete HTML attribute and the Dropdown Component’s autocomplete attribute will be hardcoded to “off” in the same nightly which should prevent the behavior you’re seeing.

1 Like

Awesome!

Thanks for the update